summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/fslurp/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/fslurp/files')
-rw-r--r--app-misc/fslurp/files/fslurp-0.9-makefile.patch19
-rw-r--r--app-misc/fslurp/files/fslurp-2.1.2-makefile.patch41
-rw-r--r--app-misc/fslurp/files/fslurp-2.1.4-makefile.patch47
3 files changed, 107 insertions, 0 deletions
diff --git a/app-misc/fslurp/files/fslurp-0.9-makefile.patch b/app-misc/fslurp/files/fslurp-0.9-makefile.patch
new file mode 100644
index 000000000000..5c2eea232082
--- /dev/null
+++ b/app-misc/fslurp/files/fslurp-0.9-makefile.patch
@@ -0,0 +1,19 @@
+--- fslurp-0.9/makefile
++++ fslurp-0.9/makefile
+@@ -6,14 +6,14 @@
+
+ INCLUDES = fslurp.h fronius.h externs.h
+
+-CFLAGS = -Wall
++CFLAGS += -Wall
+
+ LINKFLAGS = -lm
+
+ VERSION := fslurp-$(shell tail -1 version)
+
+ fslurp: $(SOURCE) $(INCLUDES)
+- gcc $(CFLAGS) -o fslurp $(SOURCE) $(LINKFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o fslurp $(SOURCE) $(LINKFLAGS)
+
+ test: fslurp
+ ./fslurp
diff --git a/app-misc/fslurp/files/fslurp-2.1.2-makefile.patch b/app-misc/fslurp/files/fslurp-2.1.2-makefile.patch
new file mode 100644
index 000000000000..487bb1fc0e6a
--- /dev/null
+++ b/app-misc/fslurp/files/fslurp-2.1.2-makefile.patch
@@ -0,0 +1,41 @@
+--- fslurp-2.1.2/Makefile
++++ fslurp-2.1.2/Makefile
+@@ -46,31 +46,31 @@
+ SIMINCLUDES = simulator.h
+
+ #DEBUGFLAGS = -g
+-CFLAGS = -c -Wall $(DEBUGFLAGS)
++CFLAGS += -c -Wall $(DEBUGFLAGS)
+
+-LDFLAGS = -lm
++LIBS = -lm
+
+ VERSION := fslurp-$(shell tail -1 version)
+
+ all: $(TARGETS)
+
+ fslurp: $(FSLURP_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet2i1s: \
+ $(SIMSOLARNET2I1S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet1i0s: \
+ $(SIMSOLARNET1I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet0i0s: \
+ $(SIMSOLARNET0I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simIFCEasy: $(SIMIFCEASY_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ test: $(TARGETS) clean
+ ./testcase.sh
diff --git a/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch b/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch
new file mode 100644
index 000000000000..f231c170a4a2
--- /dev/null
+++ b/app-misc/fslurp/files/fslurp-2.1.4-makefile.patch
@@ -0,0 +1,47 @@
+--- fslurp-2.1.4/Makefile
++++ fslurp-2.1.4/Makefile
+@@ -51,35 +51,35 @@
+ INCLUDES = fslurp.h fronius.h
+ SIMINCLUDES = simulator.h
+
+-DEBUGFLAGS = -g
+-CFLAGS = -c -Wall $(DEBUGFLAGS)
++#DEBUGFLAGS = -g
++CFLAGS += -c -Wall $(DEBUGFLAGS)
+
+-LDFLAGS = -lm
++LIBS = -lm
+
+ VERSION := fslurp-$(shell tail -1 version)
+
+ all: $(TARGETS)
+
+ fslurp: $(FSLURP_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet2i1s: \
+ $(SIMSOLARNET2I1S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet1i0s: \
+ $(SIMSOLARNET1I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simSolarNet0i0s: \
+ $(SIMSOLARNET0I0S_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ simIFCEasy: $(SIMIFCEASY_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ sim422IGTL: $(SIM422IGTL_OBJS)
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ -o $@ $(LIBS)
+
+ test: $(TARGETS) clean
+ ./testcase.sh