summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 00:53:23 +0000
committerSam James <sam@gentoo.org>2020-09-15 00:53:23 +0000
commite92fcd14a2d76daa9ae9ec7980c77ad17551abc0 (patch)
tree20e3656941a35549a7503f4e3e8321dce3df55f0 /app-misc/glastree/glastree-1.04_p20150525.ebuild
parentnet-mail/ripmime: port to EAPI 7 (diff)
downloadgentoo-e92fcd14a2d76daa9ae9ec7980c77ad17551abc0.tar.gz
gentoo-e92fcd14a2d76daa9ae9ec7980c77ad17551abc0.tar.bz2
gentoo-e92fcd14a2d76daa9ae9ec7980c77ad17551abc0.zip
app-misc/glastree: bump to 20150525 snapshot
Closes: https://bugs.gentoo.org/623466 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/glastree/glastree-1.04_p20150525.ebuild')
-rw-r--r--app-misc/glastree/glastree-1.04_p20150525.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/glastree/glastree-1.04_p20150525.ebuild b/app-misc/glastree/glastree-1.04_p20150525.ebuild
new file mode 100644
index 000000000000..8e8a41a96311
--- /dev/null
+++ b/app-misc/glastree/glastree-1.04_p20150525.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT="1dc111308356d999f2a32aa50b6a0737ec5e6b09"
+DESCRIPTION="glastree is a poor mans snapshot utility using hardlinks written in perl"
+HOMEPAGE="http://www.igmus.org/code/"
+SRC_URI="https://github.com/jeremywohl/glastree/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Date-Calc
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-posix-make.patch
+)
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/man/man1
+ emake INSTROOT="${ED}"/usr INSTMAN=share/man install
+ dodoc README CHANGES THANKS
+}