summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-02 00:12:43 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-02 00:13:38 +0100
commitd115701d7b1f05ce1e5651805d6ee9750c52456d (patch)
tree1d0349e272ab1e472adf74a4d5f5d45cf6a1ce6f /app-misc/golly/golly-4.1-r1.ebuild
parentpackage.mask: fix year net-analyzer/amap (diff)
downloadgentoo-d115701d7b1f05ce1e5651805d6ee9750c52456d.tar.gz
gentoo-d115701d7b1f05ce1e5651805d6ee9750c52456d.tar.bz2
gentoo-d115701d7b1f05ce1e5651805d6ee9750c52456d.zip
app-misc/golly: disable perl integration
requires perl with ithreads, let's not add (conditional) deps for it Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-misc/golly/golly-4.1-r1.ebuild')
-rw-r--r--app-misc/golly/golly-4.1-r1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-misc/golly/golly-4.1-r1.ebuild b/app-misc/golly/golly-4.1-r1.ebuild
new file mode 100644
index 000000000000..b502a58b492a
--- /dev/null
+++ b/app-misc/golly/golly-4.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER=3.0-gtk3
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit desktop python-single-r1 toolchain-funcs wxwidgets xdg
+
+DESCRIPTION="simulator for Conway's Game of Life and other cellular automata"
+HOMEPAGE="http://golly.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+S="${WORKDIR}/${P}-src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,sdl,tiff]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.0-CFLAGS.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ setup-wxwidgets
+}
+
+src_compile() {
+ local mymakeopts=(
+ ENABLE_SOUND=yes
+ GOLLYDIR="${EPREFIX}/usr/share/${PN}"
+ PYTHON=${EPYTHON}
+ WX_CONFIG=${WX_CONFIG}
+ AR=$(tc-getAR)
+ CC=$(tc-getCC)
+ CXX=$(tc-getCXX)
+ CXXC=$(tc-getCXX)
+ RANLIB=$(tc-getRANLIB)
+ )
+ emake -C gui-wx -f makefile-gtk "${mymakeopts[@]}"
+}
+
+src_install() {
+ # has no 'make install' Let's install files manually.
+ dobin golly bgolly
+ insinto /usr/share/${PN}
+ doins -r Help Patterns Scripts Rules docs
+
+ newicon --size 32 gui-wx/icons/appicon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Golly" ${PN} "Science"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}