summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-02-26 23:35:26 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-02-27 11:04:08 +0200
commit6b0af142d6ffd70e129175ae8d2798447cf27b6c (patch)
tree92507fff690cbdd423fbae73c0bdfe9bd1317e65 /app-misc/openrgb
parentnet-dialup/freeradius: add 3.2.2 (diff)
downloadgentoo-6b0af142d6ffd70e129175ae8d2798447cf27b6c.tar.gz
gentoo-6b0af142d6ffd70e129175ae8d2798447cf27b6c.tar.bz2
gentoo-6b0af142d6ffd70e129175ae8d2798447cf27b6c.zip
app-misc/openrgb: drop 0.7, 0.7-r1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/openrgb')
-rw-r--r--app-misc/openrgb/Manifest1
-rw-r--r--app-misc/openrgb/openrgb-0.7-r1.ebuild81
-rw-r--r--app-misc/openrgb/openrgb-0.7.ebuild72
3 files changed, 0 insertions, 154 deletions
diff --git a/app-misc/openrgb/Manifest b/app-misc/openrgb/Manifest
index 4b00e7ad8635..e0ff770dc389 100644
--- a/app-misc/openrgb/Manifest
+++ b/app-misc/openrgb/Manifest
@@ -1,2 +1 @@
-DIST OpenRGB-release_0.7.tar.bz2 28053114 BLAKE2B dfab42fca654478ab359e6e46133fc20a4bf32aca35d1b2f475d3e4e5e218f35c7e1f03be15381b0e8d874ea24254b88b8fe21548a4183b29b4c66647aeef516 SHA512 6ee605bfc91da14d34bc89fe75790f99548253e2d6aa088e20d1996577629bf15fe0fae09e65d983aa829f54cfcbd33e13f2c7d493a2776fd1723f8725b62186
DIST OpenRGB-release_0.8.tar.bz2 28631365 BLAKE2B 3b328e38f1c52646da02b0b2b2c22b1285f3b31b0a2bc684e99d491d04bd14a91b49bc196b3b81b537320cd872e5568aaa8aec34744f4f15392d9424a81ac6f0 SHA512 d69686da7cab33099b13cfb5ab876fc2db047f79aa01bf8150507ec41321b4c6c092f81623823b89916c70a1a24c4a102f77b1001c5caa721ff4c0c52e0630d2
diff --git a/app-misc/openrgb/openrgb-0.7-r1.ebuild b/app-misc/openrgb/openrgb-0.7-r1.ebuild
deleted file mode 100644
index fc7b38dbf97b..000000000000
--- a/app-misc/openrgb/openrgb-0.7-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic qmake-utils udev
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
-else
- SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
- S="${WORKDIR}/OpenRGB-release_${PV}"
- KEYWORDS="amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
-fi
-
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
-HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
-LICENSE="GPL-2"
-# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
-SLOT="0/2"
-
-RDEPEND="
- dev-libs/hidapi
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- net-libs/mbedtls:=
- virtual/libusb:1
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/nlohmann_json
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.7-plugins.patch
- "${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
- "${FILESDIR}"/OpenRGB-0.7-json.patch
-)
-
-src_prepare() {
- default
- rm -r dependencies/{hidapi,libusb,json,mbedtls}* || die
-}
-
-src_configure() {
- # Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
- append-ldflags -Wl,--export-dynamic
-
- eqmake5 \
- INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
- DEFINES+="GENTOO_PLUGINS_DIR=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}" install
-
- dodoc README.md OpenRGB.patch
- udev_dorules 60-openrgb.rules
-
- # This is for plugins. Upstream doesn't install any headers at all.
- insinto /usr/include/OpenRGB
- find . -name '*.h' -exec cp --parents '{}' "${ED}/usr/include/OpenRGB/" ';' || die
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/app-misc/openrgb/openrgb-0.7.ebuild b/app-misc/openrgb/openrgb-0.7.ebuild
deleted file mode 100644
index a8ef5e62540f..000000000000
--- a/app-misc/openrgb/openrgb-0.7.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic qmake-utils
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
-else
- SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
- S="${WORKDIR}/OpenRGB-release_${PV}"
- KEYWORDS="amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
-fi
-
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
-HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
-LICENSE="GPL-2"
-# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
-SLOT="0/2"
-
-RDEPEND="
- dev-libs/hidapi
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- net-libs/mbedtls:=
- virtual/libusb:1
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/nlohmann_json
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.7-plugins.patch
- "${FILESDIR}"/OpenRGB-0.7-udev.patch
- "${FILESDIR}"/OpenRGB-0.7-json.patch
-)
-
-src_prepare() {
- default
- rm -r dependencies/{hidapi,libusb,json,mbedtls}* || die
-}
-
-src_configure() {
- # Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
- append-ldflags -Wl,--export-dynamic
-
- eqmake5 \
- INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
- DEFINES+="GENTOO_PLUGINS_DIR=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}" install
-
- dodoc README.md OpenRGB.patch
-
- # This is for plugins. Upstream doesn't install any headers at all.
- insinto /usr/include/OpenRGB
- find . -name '*.h' -exec cp --parents '{}' "${ED}/usr/include/OpenRGB/" ';' || die
-}