summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/realpath/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/realpath/files')
-rw-r--r--app-misc/realpath/files/realpath-1.14-no-po4a.patch12
-rw-r--r--app-misc/realpath/files/realpath-1.15-build.patch35
-rw-r--r--app-misc/realpath/files/realpath-1.15-prefix.patch39
-rw-r--r--app-misc/realpath/files/realpath-1.16-nonls.patch29
-rw-r--r--app-misc/realpath/files/realpath-1.17-build.patch43
5 files changed, 158 insertions, 0 deletions
diff --git a/app-misc/realpath/files/realpath-1.14-no-po4a.patch b/app-misc/realpath/files/realpath-1.14-no-po4a.patch
new file mode 100644
index 000000000000..cfa780553646
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.14-no-po4a.patch
@@ -0,0 +1,12 @@
+Don't require po4a at build time.
+http://bugs.gentoo.org/269905
+
+--- realpath-1.14-orig/po/Makefile 2009-02-22 12:56:47.000000000 +0100
++++ realpath-1.14/po/Makefile 2009-05-19 23:45:26.000000000 +0200
+@@ -4,5 +4,5 @@
+ #
+
+ ALL_TARGET=
+-SUBDIRS=bin man
++SUBDIRS=bin
+ include ../common.mk
diff --git a/app-misc/realpath/files/realpath-1.15-build.patch b/app-misc/realpath/files/realpath-1.15-build.patch
new file mode 100644
index 000000000000..7b90a0c0c27b
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.15-build.patch
@@ -0,0 +1,35 @@
+diff --git a/common.mk b/common.mk
+index 18f539c..142f7e6 100644
+--- a/common.mk
++++ b/common.mk
+@@ -34,16 +34,11 @@ webcgidir := $(prefix)/lib/cgi-bin
+ applicationsdir := $(prefix)/share/applications
+
+ PERL := /usr/bin/perl
+-CC := gcc
+-CFLAGS = -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+-LDFLAGS :=
+-LIBS :=
++CC ?= gcc
++CFLAGS += -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
++LDFLAGS +=
++LIBS +=
+
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+
+
+ # determine our version number
+@@ -60,9 +55,6 @@ ifndef VERSION
+ unexport CDPATH ENV
+
+ ifdef DESTDIR
+- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
+- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
+- endif
+ override ddirshort := DESTDIR
+ export ddirshort
+ endif
diff --git a/app-misc/realpath/files/realpath-1.15-prefix.patch b/app-misc/realpath/files/realpath-1.15-prefix.patch
new file mode 100644
index 000000000000..f9534641382f
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.15-prefix.patch
@@ -0,0 +1,39 @@
+diff --git a/common.mk b/common.mk
+index 2443a40..0a342ee 100644
+--- a/common.mk
++++ b/common.mk
+@@ -8,17 +8,19 @@ override TOPDIR := $(dir $(call getCurrentMakefileName))
+
+ override PACKAGE := realpath
+
+-PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
++#PATH := /usr/bin:/usr/sbin:/bin:/sbin:$(PATH)
++
++SHELL := @GENTOO_PORTAGE_EPREFIX@/bin/bash
+
+ # build abstraction
+-install_file := install -p -o root -g root -m 644
+-install_script := install -p -o root -g root -m 755
+-install_dir := install -d -o root -g root -m 755
++install_file := install -p -m 644
++install_script := install -p -m 755
++install_dir := install -d -m 755
+ install_link := ln -sf
+ compress := gzip -9f
+
+-prefix := /usr
+-etcdir := /etc/$(PACKAGE)
++prefix := @GENTOO_PORTAGE_EPREFIX@/usr
++etcdir := @GENTOO_PORTAGE_EPREFIX@/etc/$(PACKAGE)
+ bindir := $(prefix)/bin
+ sbindir := $(prefix)/sbin
+ mandir := $(prefix)/share/man
+@@ -33,7 +35,7 @@ webdocrootdir := /var/www
+ webcgidir := $(prefix)/lib/cgi-bin
+ applicationsdir := $(prefix)/share/applications
+
+-PERL := /usr/bin/perl
++PERL := @GENTOO_PORTAGE_EPREFIX@/usr/bin/perl
+ CC ?= gcc
+ CFLAGS += -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+ LDFLAGS +=
diff --git a/app-misc/realpath/files/realpath-1.16-nonls.patch b/app-misc/realpath/files/realpath-1.16-nonls.patch
new file mode 100644
index 000000000000..d758d03ff89b
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.16-nonls.patch
@@ -0,0 +1,29 @@
+ src/realpath.c | 6 +-----
+ 1 files changed, 1 insertions(+), 5 deletions(-)
+
+diff --git a/src/realpath.c b/src/realpath.c
+index 76fc909..e2cf86f 100644
+--- a/src/realpath.c
++++ b/src/realpath.c
+@@ -23,10 +23,9 @@
+ #include <errno.h>
+ #include <getopt.h>
+ #include <stdarg.h>
+-#include <libintl.h>
+ #include <locale.h>
+
+-#define _(String) gettext (String)
++#define _(String) (String)
+
+ static char *stripdir(char * dir, char *buf, int maxlen);
+
+@@ -116,9 +115,6 @@ int main(int argc, char **argv) {
+
+ myname = ( p = strchr(argv[0], '/') ) ? p+1 : argv[0];
+
+- setlocale(LC_ALL, "");
+- bindtextdomain(PACKAGE, LOCALEDIR);
+- textdomain(PACKAGE);
+
+
+ parse_options(argc, argv);
diff --git a/app-misc/realpath/files/realpath-1.17-build.patch b/app-misc/realpath/files/realpath-1.17-build.patch
new file mode 100644
index 000000000000..c4a8b3dfc9b9
--- /dev/null
+++ b/app-misc/realpath/files/realpath-1.17-build.patch
@@ -0,0 +1,43 @@
+--- a/common.mk
++++ b/common.mk
+@@ -33,16 +33,9 @@
+ applicationsdir := $(prefix)/share/applications
+
+ PERL := /usr/bin/perl
+-CC := gcc
+-CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Werror -g -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
+-LIBS :=
+-
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+-
++CC ?= gcc
++CFLAGS += $(CPPFLAGS) -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"' -DPACKAGE='"$(PACKAGE)"' -DLOCALEDIR='"$(nlsdir)"'
++LIBS +=
+
+ # determine our version number
+ ifndef VERSION
+@@ -58,9 +51,6 @@
+ unexport CDPATH ENV
+
+ ifdef DESTDIR
+- ifneq ($(DESTDIR),$(abspath $(DESTDIR)))
+- $(error DESTDIR "$(DESTDIR)" is not an absolute path)
+- endif
+ override ddirshort := DESTDIR
+ export ddirshort
+ endif
+@@ -108,7 +99,9 @@
+ esac; fi;
+ endef
+ else
+- msg := :
++ define msg
++ :
++ endef
+ endif
+
+ msgprefix := *$(subst * ,*,$(wordlist 1,$(MAKELEVEL),* * * * * * * * * * * * * * * * * *))