summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-28 17:21:59 -0500
committerMatt Turner <mattst88@gentoo.org>2023-03-01 11:16:29 -0500
commit17760110ee610d018184414c15b0f441c9d41f58 (patch)
tree0fc423de03387672632f5ac6aa1a094c6ff415ec /app-misc/vit/vit-2.2.0.ebuild
parentdev-python/tasklib: Add new package, version 2.5.1 (diff)
downloadgentoo-17760110ee610d018184414c15b0f441c9d41f58.tar.gz
gentoo-17760110ee610d018184414c15b0f441c9d41f58.tar.bz2
gentoo-17760110ee610d018184414c15b0f441c9d41f58.zip
app-misc/vit: Version bump to 2.2.0
Bug: https://bugs.gentoo.org/881109 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/vit/vit-2.2.0.ebuild')
-rw-r--r--app-misc/vit/vit-2.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/vit/vit-2.2.0.ebuild b/app-misc/vit/vit-2.2.0.ebuild
new file mode 100644
index 000000000000..0890db739edf
--- /dev/null
+++ b/app-misc/vit/vit-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A lightweight, fast, curses-based front end to Taskwarrior"
+HOMEPAGE="
+ https://github.com/vit-project/vit
+ https://pypi.org/project/vit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/tasklib-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.2[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="app-misc/task"
+
+distutils_enable_tests pytest