summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-09 18:08:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-09 18:09:05 +0200
commit1796f294570cda0fece20e6e1145ee2c2b5d30e4 (patch)
tree5afad2864ff42bbf9f5d9f22f0980dac42a72449 /app-misc
parentmail-filter/afew: Enable py3.11 (diff)
downloadgentoo-1796f294570cda0fece20e6e1145ee2c2b5d30e4.tar.gz
gentoo-1796f294570cda0fece20e6e1145ee2c2b5d30e4.tar.bz2
gentoo-1796f294570cda0fece20e6e1145ee2c2b5d30e4.zip
app-misc/timew-report: EAPI, PEP517, py3.11
Closes: https://bugs.gentoo.org/896600 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/timew-report/Manifest1
-rw-r--r--app-misc/timew-report/timew-report-1.4.0-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/timew-report/Manifest b/app-misc/timew-report/Manifest
index 3adcf730f41a..e0eacf9f7372 100644
--- a/app-misc/timew-report/Manifest
+++ b/app-misc/timew-report/Manifest
@@ -1 +1,2 @@
+DIST timew-report-1.4.0.gh.tar.gz 6815 BLAKE2B a0529f575d324a92955eef2b94f302fc61fd09f9b85a092e4b7c5993c1710a189007be900e212bc15a3a29db73feb14d246e2f78a5e2965e26eec05204cc1e34 SHA512 bb1144b0268788c569fef68d10e16311e09f390e66992e71d850ef241de21c3cb67b8f696d776e673856ef53f5205873970b1fc2e06b62696181074090bd58a8
DIST timew-report-1.4.0.tar.gz 6815 BLAKE2B a0529f575d324a92955eef2b94f302fc61fd09f9b85a092e4b7c5993c1710a189007be900e212bc15a3a29db73feb14d246e2f78a5e2965e26eec05204cc1e34 SHA512 bb1144b0268788c569fef68d10e16311e09f390e66992e71d850ef241de21c3cb67b8f696d776e673856ef53f5205873970b1fc2e06b62696181074090bd58a8
diff --git a/app-misc/timew-report/timew-report-1.4.0-r1.ebuild b/app-misc/timew-report/timew-report-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..7a298dbc18c1
--- /dev/null
+++ b/app-misc/timew-report/timew-report-1.4.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An interface for Timewarrior report data"
+HOMEPAGE="
+ https://github.com/lauft/timew-report/
+ https://pypi.org/project/timew-report/
+"
+SRC_URI="
+ https://github.com/lauft/timew-report/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-misc/timew
+"
+BDEPEND="
+ dev-python/deprecation[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest