summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-01-09 11:45:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-01-09 11:45:00 -0800
commit302227a72b175dfffd851de4d69ae173572f8786 (patch)
treee496cec124495c92ef38c473d960cbb049d662b3 /app-misc
parentsys-kernel/vanilla-sources-4.4.250: Version bump (diff)
downloadgentoo-302227a72b175dfffd851de4d69ae173572f8786.tar.gz
gentoo-302227a72b175dfffd851de4d69ae173572f8786.tar.bz2
gentoo-302227a72b175dfffd851de4d69ae173572f8786.zip
app-misc/tmuxp-1.7.0: Version bump
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/files/tmuxp-1.7.0-tests.patch15
-rw-r--r--app-misc/tmuxp/tmuxp-1.7.0.ebuild46
3 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 2c372c437f90..db5be3913be3 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -3,3 +3,4 @@ DIST tmuxp-1.5.5.tar.gz 856665 BLAKE2B fa18222840b9c221de48a78291243776a66a7aec3
DIST tmuxp-1.5.6.tar.gz 883700 BLAKE2B c8ad08c709aa1763cc046a05c6241983d2cdd33ca530ce0510ae7bb68ce3e340d40c6ec23c9544ef8b0d8da38aad74305e13d7b6348b0f46da929e94b3e862ff SHA512 1db74aa9ee6274aacec127aff210e8ed64176142991a9691c31c59ef0370503dddeb35b69c0a8229204968308c68788d408d6a5e0bc2ad1fb3320727ea4994f9
DIST tmuxp-1.6.2.tar.gz 1014758 BLAKE2B c6c60978938892311151cfff35bdc74e2daa9a615b2952a14c4a0020e434af7c28d36466a5ae82db683c6bda9a95f12f7e032d04eb58c5b164aeb05b144b2005 SHA512 a38c3f46a726df0cd885113d82ed5a186d68f6d643a7bde6d169908373e6881fac14c8c46c00ede727e47e4e1af5f9d3cd79cb0057457478ace1ec0ba0632cfb
DIST tmuxp-1.6.4.tar.gz 1015684 BLAKE2B 4f8d34ab1e1bd8e46e89e49ac92ce0a05b614bd7b43ce910120f12a46fb3ab143330975352cf2275999146ba005646c7c5aa07b7cc616ae80265edb4e173cf34 SHA512 482ba47652090a13d7866695b2639ab580c0cca5f6935f58e0be6867efde298c6f3350f65c231dec59a3f2dc1e0f795b02df1ad24d5ace6e7ee6aecdd60a9611
+DIST tmuxp-1.7.0.tar.gz 1027071 BLAKE2B d1806794e11e651e7ba826d7b28a9b0f467272d2972b06be4036919a08a5ad36140aa09f975da41a2a4bd8a71b25f38c8d08d8dd37cf2b371441a3557880146a SHA512 0cfba5375f35957e3db15c61876b4a142d4a13411e67dd7ba9c643e1bfe754e71d02773e10336f83613b90e6211d8bb9b1132fae4e890c8467b638e605dc2108
diff --git a/app-misc/tmuxp/files/tmuxp-1.7.0-tests.patch b/app-misc/tmuxp/files/tmuxp-1.7.0-tests.patch
new file mode 100644
index 000000000000..9be2392557b1
--- /dev/null
+++ b/app-misc/tmuxp/files/tmuxp-1.7.0-tests.patch
@@ -0,0 +1,15 @@
+diff --git a/tests/test_cli.py b/tests/test_cli.py
+index e5a7f93..de132db 100644
+--- a/tests/test_cli.py
++++ b/tests/test_cli.py
+@@ -15,6 +15,10 @@ import pytest
+ import click
+ import kaptan
+ from click.testing import CliRunner
++
++import sys
++import pathlib
++sys.path.extend([str(p) for p in pathlib.Path(__file__, '..', 'fixtures/pluginsystem/plugins').resolve().iterdir() if p.is_dir()])
+ from tmuxp_test_plugin_bwb.plugin import PluginBeforeWorkspaceBuilder
+
+ import libtmux
diff --git a/app-misc/tmuxp/tmuxp-1.7.0.ebuild b/app-misc/tmuxp/tmuxp-1.7.0.ebuild
new file mode 100644
index 000000000000..aab4054c7519
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.7.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ >=dev-python/kaptan-0.5.10[${PYTHON_USEDEP}]
+ >=dev-python/libtmux-0.8.5[${PYTHON_USEDEP}]
+ <dev-python/libtmux-0.9[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-4.1.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tmuxp-1.6.4-tests.patch"
+ "${FILESDIR}/tmuxp-1.7.0-tests.patch"
+)
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ SHELL="/bin/bash" pytest -vv || die "Tests fail with ${EPYTHON}"
+}