summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-31 22:03:17 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-31 22:03:17 +0200
commit5036c1fea222b3671b9e63c9b87a49b4a76ef5f8 (patch)
tree186eae30ff15dc51f9685e30d0b5435364af4f3d /app-misc
parentdev-db/sqlite: Stabilize 3.39.2 ppc64, #862429 (diff)
downloadgentoo-5036c1fea222b3671b9e63c9b87a49b4a76ef5f8.tar.gz
gentoo-5036c1fea222b3671b9e63c9b87a49b4a76ef5f8.tar.bz2
gentoo-5036c1fea222b3671b9e63c9b87a49b4a76ef5f8.zip
app-misc/birthday: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/birthday/birthday-1.6.2-r2.ebuild (renamed from app-misc/birthday/birthday-1.6.2-r1.ebuild)20
-rw-r--r--app-misc/birthday/files/birthday-1.6.2-makefile.patch44
2 files changed, 48 insertions, 16 deletions
diff --git a/app-misc/birthday/birthday-1.6.2-r1.ebuild b/app-misc/birthday/birthday-1.6.2-r2.ebuild
index 4d2088dc58c5..53041e6b6378 100644
--- a/app-misc/birthday/birthday-1.6.2-r1.ebuild
+++ b/app-misc/birthday/birthday-1.6.2-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -13,20 +13,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
-src_prepare() {
- # Don't strip, install in correct share dir and respect CFLAGS
- sed \
- -e "s@install -s@install@g" \
- -e "s@#SHARE@SHARE@g" \
- -e "s@-O2@${CFLAGS}@g" \
- -i Makefile || die
- sed \
- -e 's@grep -v@grep --binary-files=text -v@g' \
- -i runtest.sh || die
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
- default
-}
-
-src_compile() {
- emake CC="$(tc-getCC)"
+src_configure() {
+ tc-export CC
}
diff --git a/app-misc/birthday/files/birthday-1.6.2-makefile.patch b/app-misc/birthday/files/birthday-1.6.2-makefile.patch
new file mode 100644
index 000000000000..f48102d929b7
--- /dev/null
+++ b/app-misc/birthday/files/birthday-1.6.2-makefile.patch
@@ -0,0 +1,44 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,7 +12,7 @@
+ else
+ OSCFLAGS=-Wall -Wstrict-prototypes
+ endif
+-CFLAGS=-O2 $(DEBUG) -D$(OS) $(OSCFLAGS)
++CFLAGS += $(DEBUG) -D$(OS) $(OSCFLAGS)
+
+ # engine
+ ENGSRC=bdengine.c xmalloc.c
+@@ -48,16 +48,15 @@
+
+ else
+ birthday: $(CMDOBJ)
+- $(CC) $(LDFLAGS) $(CMDOBJ) -o $@
++ $(CC) $(LDFLAGS) $(CMDOBJ) -o $@ $(LIBS)
+
+ # you can override this to use the new FHS locations.
+-SHARE=
+-#SHARE=/share
++SHARE=/share
+
+ install: birthday birthday.man
+- install -d $(DESTDIR)/usr/bin $(DESTDIR)/usr$(SHARE)/man/man1
+- install -s birthday $(DESTDIR)/usr/bin/birthday
+- install -m 0644 birthday.man $(DESTDIR)/usr$(SHARE)/man/man1/birthday.1
++ install -d $(DESTDIR)$(EPREFIX)/usr/bin $(DESTDIR)$(EPREFIX)/usr$(SHARE)/man/man1
++ install birthday $(DESTDIR)$(EPREFIX)/usr/bin/birthday
++ install -m 0644 birthday.man $(DESTDIR)$(EPREFIX)/usr$(SHARE)/man/man1/birthday.1
+
+ test: birthday
+ sh runtest.sh -exec `pwd`/birthday test/*.t
+--- a/runtest.sh
++++ b/runtest.sh
+@@ -7,7 +7,7 @@
+ unset PASSED FAILED TAKEN KEEP
+
+ extract_section() {
+- sed -ne "/^\\*$1/,/^\\*/p" "$2" | grep -v '^*'
++ sed -ne "/^\\*$1/,/^\\*/p" "$2" | grep --binary-files=text -v '^*'
+ }
+
+ runtest() {