summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2020-09-03 12:09:10 -0600
committerDenis Dupeyron <calchan@gentoo.org>2020-09-03 12:09:49 -0600
commit5570aad5d2d8b3591dbc765030fce08ecbae0675 (patch)
treeafe9ee8c61a99e2a871c38c222c722cf0dcc2d19 /app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
parentsys-kernel/gentoo-kernel-bin: Bump to 5.4.62 (diff)
downloadgentoo-5570aad5d2d8b3591dbc765030fce08ecbae0675.tar.gz
gentoo-5570aad5d2d8b3591dbc765030fce08ecbae0675.tar.bz2
gentoo-5570aad5d2d8b3591dbc765030fce08ecbae0675.zip
app-mobilephone/adb-sync: bump to 0_p20190101, add Python 3.8 (bug 738158)
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
Diffstat (limited to 'app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild')
-rw-r--r--app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
new file mode 100644
index 000000000000..9ad99a6a5711
--- /dev/null
+++ b/app-mobilephone/adb-sync/adb-sync-0_p20190101.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit python-single-r1
+
+COMMIT=fb7c549753de7a5579ed3400dd9f8ac71f7bf1b1
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ dev-util/android-tools
+ channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/adb-sync-${COMMIT}"
+
+src_install() {
+ dodoc README.md
+ python_doscript adb-sync
+ use channel && dobin adb-channel
+}