summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-07-01 15:54:46 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-07-01 16:09:29 +0200
commit49f76ca53c248861420c1f53778f6892a0cdd0a4 (patch)
tree0857d8843e957ac5dd3b78f06c783989e8f7f480 /app-mobilephone
parentapp-mobilephone/scrcpy: drop 2.3.1-r2 (diff)
downloadgentoo-49f76ca53c248861420c1f53778f6892a0cdd0a4.tar.gz
gentoo-49f76ca53c248861420c1f53778f6892a0cdd0a4.tar.bz2
gentoo-49f76ca53c248861420c1f53778f6892a0cdd0a4.zip
app-mobilephone/scrcpy: add 2.5
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scrcpy/Manifest2
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.5.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-mobilephone/scrcpy/Manifest b/app-mobilephone/scrcpy/Manifest
index 31c7cfc28f60..d7644e8cb7e9 100644
--- a/app-mobilephone/scrcpy/Manifest
+++ b/app-mobilephone/scrcpy/Manifest
@@ -1,2 +1,4 @@
DIST scrcpy-2.4.tar.gz 411206 BLAKE2B 878e20b5a8b6cbe81491baf330500c3ffa779e6a1d52b1624fd8f1862768668bd73b9845cc983a6f112db88f77b5f414c1762e616999ceb24ba3733775bf932d SHA512 05467a476a9a7eb3034eb5c16875a00dceedf25a9a3acde26738c6dfbc314e9c2a515feb3f6050c7b47436cc2a44ae2d05664b1783b1b1d7c63660044404b3d6
+DIST scrcpy-2.5.tar.gz 415854 BLAKE2B ce79c885c89728d90c7a30d3670107a2a3c0be10d9d25dca9dfc916ec2b096a1ce967f7b1c73384cd630fd8418498bebb65aeeb8a0b6423d6dcb4fb3d3d7415a SHA512 676078e55f287f84847af898d39bc073bda7accf8905f84f87c2ec927dff9d71133a69dece9bd65fc6e4778204f5f5287239e163f88a5bdb900e1f10427d4238
DIST scrcpy-server-v2.4 69007 BLAKE2B c34d75bb34dcdaf27111366575f46d8e1d54c3d9a0eca8cb569367204a3e51e4d5b05f8a4d2de9868fe48ca4e3d323c583a99da86132e533dbede78314ca447a SHA512 6618e3bd23f139f5ed10d00dd8f8bb259bd9eaa5bca4625d3da2b38c2d1aa2cd10b6e412b6e79b1b0aecc291bde9dd2f2fddf416544b18046648a6c2b92e3368
+DIST scrcpy-server-v2.5 69624 BLAKE2B a4c8aaab320e07d0c7086238a2f1e842df40ba8a85b7ed3f519f2e6f8511f6d513c80e6693a1db6c69f2c15e71e7d08db3d37ebefa47633efdaae2e706809e1c SHA512 4c5ff163b4cb232d34f0cf8788bf01c3a0b08bfe0ab854da58df6f9d2296387225b822a639d35d90c307b0c6ff9cde6281ad5fd3985717645e0b6ec3ded0150b
diff --git a/app-mobilephone/scrcpy/scrcpy-2.5.ebuild b/app-mobilephone/scrcpy/scrcpy-2.5.ebuild
new file mode 100644
index 000000000000..ef5acfc0b38d
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-2.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="
+ https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ media-libs/libsdl2[X]
+ media-video/ffmpeg:=
+ virtual/libusb:1
+"
+# Manual install for ppc64 until bug #723528 is fixed
+RDEPEND="
+ ${DEPEND}
+ !ppc64? ( dev-util/android-tools )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+
+ einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
+ einfo "scrcpy will not start, in which case start the program by exporting the"
+ einfo "environment variable SDL_AUDIODRIVER=pipewire."
+ einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
+}