summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-24 17:06:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-24 17:40:26 +0100
commitaac9e457aa3d5493fca4c8cb3227803ff5df5af8 (patch)
tree09db33793cf175fd9e5dcc31590ba3f264b2baaf /app-mobilephone
parentsys-kernel/linux-firmware: Pass savedconfig vals as a file (diff)
downloadgentoo-aac9e457aa3d5493fca4c8cb3227803ff5df5af8.tar.gz
gentoo-aac9e457aa3d5493fca4c8cb3227803ff5df5af8.tar.bz2
gentoo-aac9e457aa3d5493fca4c8cb3227803ff5df5af8.zip
app-mobilephone/scrcpy: Add := dep on media-video/ffmpeg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.3.1-r1.ebuild (renamed from app-mobilephone/scrcpy/scrcpy-2.3.1.ebuild)20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-mobilephone/scrcpy/scrcpy-2.3.1.ebuild b/app-mobilephone/scrcpy/scrcpy-2.3.1-r1.ebuild
index b353534c5781..ef5acfc0b38d 100644
--- a/app-mobilephone/scrcpy/scrcpy-2.3.1.ebuild
+++ b/app-mobilephone/scrcpy/scrcpy-2.3.1-r1.ebuild
@@ -8,19 +8,25 @@ inherit meson xdg
DESCRIPTION="Display and control your Android device"
HOMEPAGE="https://github.com/Genymobile/scrcpy"
# Source code and server part on Android device
-SRC_URI="https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}"
+SRC_URI="
+ https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}
+"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-DEPEND="media-libs/libsdl2[X]
- media-video/ffmpeg
- virtual/libusb:1"
+DEPEND="
+ media-libs/libsdl2[X]
+ media-video/ffmpeg:=
+ virtual/libusb:1
+"
# Manual install for ppc64 until bug #723528 is fixed
-RDEPEND="${DEPEND}
- !ppc64? ( dev-util/android-tools )"
+RDEPEND="
+ ${DEPEND}
+ !ppc64? ( dev-util/android-tools )
+"
src_configure() {
local emesonargs=(