summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-12-22 21:34:55 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-12-22 21:35:35 +0100
commitac1498dc635bd3ff1d3bc5156a38ed8aecb2a8d4 (patch)
tree2560a0ef1cf77a75d5a41492138c9ae7bd015cb0 /app-mobilephone
parentgames-emulation/dosbox-staging: drop 0.78.1, 0.79.0 (diff)
downloadgentoo-ac1498dc635bd3ff1d3bc5156a38ed8aecb2a8d4.tar.gz
gentoo-ac1498dc635bd3ff1d3bc5156a38ed8aecb2a8d4.tar.bz2
gentoo-ac1498dc635bd3ff1d3bc5156a38ed8aecb2a8d4.zip
app-mobilephone/scrcpy: add 1.25
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scrcpy/Manifest2
-rw-r--r--app-mobilephone/scrcpy/scrcpy-1.25.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/app-mobilephone/scrcpy/Manifest b/app-mobilephone/scrcpy/Manifest
index 54618f53cd28..981cb7b2e7d3 100644
--- a/app-mobilephone/scrcpy/Manifest
+++ b/app-mobilephone/scrcpy/Manifest
@@ -1,2 +1,4 @@
DIST scrcpy-1.24.tar.gz 424970 BLAKE2B 33a0249ee9e9579b3bf8e0a4f94427b0c44b2a3aaf953c527a072d4f69ab89a680107b234803415741ba003ea6a8a207d33ce0d40341560fd6d85cda3807f7a6 SHA512 0eda7d6b0fb7339e1e32114d861194fd6bfce5ddb15d8d241f94278cb5800c2dd6c3bd69ea0b09b2bd5137757e85d679b2c789218e6933d83df4bc07dac09b2e
+DIST scrcpy-1.25.tar.gz 345594 BLAKE2B 9be58de258d2e048fc87ef642ba668ad7427faea51d6bd06d48d1ca61a5c55bbce2b758b445d21ea3052ac63809769043e57a28502c53fae98079056029ded1f SHA512 7f28adb69becdc247156d664744ef382cc9ac5e746d2be9c833a53309386c22eb90893b499aee80404cb9903ea40ce5f389b41f2201bf85801e1b8ab920b4eb0
DIST scrcpy-server-v1.24 41159 BLAKE2B 332f05198bd64392ed870add260249d7e549ceb963e707ee6a249c08197c2c6a52bc427be0dfa99a479d61926d1ccea1471f5a448816b4b157c933d7a17cd75f SHA512 1bbc921e954c722307ef4fb2e1478954f6bf14544da362a9edeefd0f90def435bee409130d2ef2fddee98ec6255e12e9bda595507fec479f3feae0a57fb78236
+DIST scrcpy-server-v1.25 42151 BLAKE2B 90789c8b259f9a63820652f8884b51abe1040201f37788542796fbff6445bc13259e2aaf635c99c6ccdb515d8fd4b0b3bcd54d8972d134086f05d149a5073d41 SHA512 2861f423b6c982354c5959570708b51832e18b9d376397f98a78c8d6137af22bb3f19cbce501d7f413276362e9ac9e0358b8984566ff04102a3720074ff1fea1
diff --git a/app-mobilephone/scrcpy/scrcpy-1.25.ebuild b/app-mobilephone/scrcpy/scrcpy-1.25.ebuild
new file mode 100644
index 000000000000..a244fae445e4
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-1.25.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="lto"
+
+DEPEND="media-libs/libsdl2[X]
+ media-video/ffmpeg
+ virtual/libusb:1"
+# Manual install for ppc64 until bug #723528 is fixed
+RDEPEND="${DEPEND}
+ !ppc64? ( dev-util/android-tools )"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use lto b_lto)
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+}