summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-06 11:53:16 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-06 11:58:31 -0400
commit542c50b2472b3e86a4207cc40f038b255c4860d8 (patch)
tree94b2f8afa2678121339f5757e194e405101c770d /app-office/auto-multiple-choice
parentapp-office/auto-multiple-choice: Require netpbm[png] (diff)
downloadgentoo-542c50b2472b3e86a4207cc40f038b255c4860d8.tar.gz
gentoo-542c50b2472b3e86a4207cc40f038b255c4860d8.tar.bz2
gentoo-542c50b2472b3e86a4207cc40f038b255c4860d8.zip
app-office/auto-multiple-choice: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-office/auto-multiple-choice')
-rw-r--r--app-office/auto-multiple-choice/Manifest1
-rw-r--r--app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild96
-rw-r--r--app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch54
-rw-r--r--app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch10
4 files changed, 0 insertions, 161 deletions
diff --git a/app-office/auto-multiple-choice/Manifest b/app-office/auto-multiple-choice/Manifest
index ae4e3760cf6a..5596bb1b213b 100644
--- a/app-office/auto-multiple-choice/Manifest
+++ b/app-office/auto-multiple-choice/Manifest
@@ -1,2 +1 @@
-DIST auto-multiple-choice_1.3.0_sources.tar.gz 4328255 BLAKE2B 7c6337cfa0a12d8dcd9fa640e636c300234ba7e7a34e95a523c5f9836f934da336f6ce792932fffb97b28ae02c577166a3d4d3ea4fd6959786a5c60510b454a2 SHA512 fcfacd071072f5773556c706b6fa0aea4ff3f3752f3a1f40c9e6de7ec870e939adc57e6bd4c90cac80241cc798e02a71c9fc80d9ccf25ad3a10752f937d06da5
DIST auto-multiple-choice_1.6.0_sources.tar.gz 9597797 BLAKE2B 2ce5162223802a7e9d6025e0a324b507e218389cff63ca863846bd2be36fc7a3a0d6aede3b2d85da4c37b9c25cadaa544c8b9d79458a0936d8c1b9fce244a5da SHA512 b6640ae1bbea9438de38f55b4e0cb6fa93de3598ecf75bce5a6891f8db568bff7aa7ca286bfb07646fd5bed6625d434093e3b574b96711a65fbd10f9ddadcf74
diff --git a/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild b/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild
deleted file mode 100644
index c33d12be5ccf..000000000000
--- a/app-office/auto-multiple-choice/auto-multiple-choice-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs perl-functions latex-package
-
-DESCRIPTION="Create and manage multiple choice questionnaries, including automated marking"
-HOMEPAGE="http://www.auto-multiple-choice.net/"
-SRC_URI="http://download.auto-multiple-choice.net/${PN}_${PV}_sources.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-LANGS="ar es fr ja"
-# we deliberately always install de and en, since this way we dont get a problem
-# with globs and empty directories...
-#
-for lala in ${LANGS}; do
- IUSE="${IUSE} l10n_${lala}"
-done
-
-COMMON_DEPEND="
- app-text/texlive[extra,graphics,png,pstricks,science,truetype,xml,X,luatex,xetex,humanities,publishers]
- app-text/poppler:=
- dev-perl/XML-LibXML
- media-libs/netpbm
- media-libs/opencv
- l10n_fr? ( app-text/texlive[l10n_fr] )
- l10n_ja? ( app-text/texlive[l10n_ja] )
-"
-DEPEND="${COMMON_DEPEND}
- app-text/dblatex
- app-text/docbook-xml-simple-dtd:*
- app-text/docbook-xsl-stylesheets
-"
-RDEPEND="${COMMON_DEPEND}
- app-text/pdftk
- dev-lang/perl:=
- dev-perl/Glib-Object-Introspection
- dev-perl/Gtk2
- dev-perl/Gtk2-Notify
- media-gfx/imagemagick
- dev-perl/XML-Writer
- dev-perl/Archive-Zip
- dev-perl/DBI
- dev-perl/Text-CSV
- dev-perl/DBD-SQLite
- dev-perl/Net-CUPS
- dev-perl/Email-Address
- dev-perl/Email-MIME
- dev-perl/Email-Sender
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.0-desktop.patch"
- "${FILESDIR}/${PN}-1.3.0-conf.patch"
-)
-
-src_prepare() {
- default
-
- local la
- for la in ${LANGS} ; do
- if ! use l10n_${la} ; then
- # remove languages that we dont want to install. no error on nonexisting files.
- rm -vf "I18N/lang/${la}.po"
- rm -vf "doc/auto-multiple-choice.${la}.in.xml" "doc/doc-xhtml-site.${la}.xsl.in"
- rm -rvf "doc/html/auto-multiple-choice.${la}" "doc/modeles/${la}"
- sed -e "s: doc/doc-xhtml-site\\.${la}\\.xsl: :g" -i Makefile || die
- fi
- done
-}
-
-src_compile() {
- perl_set_version
- export VENDOR_LIB PVR
- export TEXINPUTS="/usr/share/dblatex/latex/style:/usr/share/dblatex/latex/misc:/usr/share/dblatex/latex/graphics:"
-
- export MAKEOPTS="-j1"
- # when doing a parallel build, the package is acting decidedly odd
- # e.g., the build seems to succeed while actually stuff fails
- # and subsequent error messages do not have any relation to the real problem
- # So let's keep this also for easier debugging
-
- emake \
- GCC_NETPBM="-I/usr/include/netpbm/ -lnetpbm" \
- GCC="$(tc-getCC)" \
- GCC_PP="$(tc-getCXX)"
-}
-
-src_install() {
- default
-}
diff --git a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch
deleted file mode 100644
index 2e5e0cdd58c0..000000000000
--- a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-conf.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -ruN auto-multiple-choice-1.3.0.orig/Makefile.conf auto-multiple-choice-1.3.0/Makefile.conf
---- auto-multiple-choice-1.3.0.orig/Makefile.conf 2016-03-09 20:17:01.000000000 +0100
-+++ auto-multiple-choice-1.3.0/Makefile.conf 2017-01-21 21:55:32.649670839 +0100
-@@ -33,13 +33,13 @@
- # directory for executable
- BINDIR=/usr/bin
- # directory for perl modules
--PERLDIR=/usr/share/perl5
-+PERLDIR=$(VENDOR_LIB)
- # directory for some AMC executables, not to be used by end-user
- MODSDIR=/usr/lib/AMC
- # directory for LaTeX style file
--TEXDIR=/usr/share/texmf/tex/latex/AMC
-+TEXDIR=/usr/share/texmf-site/tex/latex/AMC
- # directory for LaTeX doc
--TEXDOCDIR=/usr/share/doc/texmf/AMC/
-+TEXDOCDIR=/usr/share/texmf-site/doc/AMC/
- # directory for man (1) files
- MAN1DIR=/usr/share/man/man1
- # directory for desktop file
-@@ -54,7 +54,7 @@
- # directory for AMC packaged models
- MODELSDIR=/usr/share/auto-multiple-choice/models
- # directory for documentation (will use html/auto-multiple-choice.* subdirs for HTML docs)
--DOCDIR=/usr/share/doc/auto-multiple-choice-doc
-+DOCDIR=/usr/share/doc/$(PVR)
-
- # directory for Shared MIME-info Database
- SHARED_MIMEINFO_DIR=/usr/share/mime/packages
-@@ -91,8 +91,8 @@
-
- # INSTALL USER AND GROUP
-
--ifneq ($(SYSTEM_TYPE),rpm)
--INSTALL_USER=root
--INSTALL_GROUP=root
--endif
-+#ifneq ($(SYSTEM_TYPE),rpm)
-+#INSTALL_USER=root
-+#INSTALL_GROUP=root
-+#endif
-
-diff -ruN auto-multiple-choice-1.3.0.orig/doc/Makefile auto-multiple-choice-1.3.0/doc/Makefile
---- auto-multiple-choice-1.3.0.orig/doc/Makefile 2016-03-14 19:40:45.000000000 +0100
-+++ auto-multiple-choice-1.3.0/doc/Makefile 2017-01-21 21:28:29.438603307 +0100
-@@ -64,7 +64,7 @@
- esac
-
- %.pdf: %.tex $(BLOCK_IMAGES:.svg=.pdf)
-- export TEXINPUTS=./img_pdf/: ; case $< in \
-+ export TEXINPUTS=$(TEXINPUTS):./img_pdf/: ; case $< in \
- *.ja.tex) \
- sed -i -e '/setuplocale/a\
- \\usepackage{xeCJK}\
diff --git a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch b/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch
deleted file mode 100644
index 3c6225dcc054..000000000000
--- a/app-office/auto-multiple-choice/files/auto-multiple-choice-1.3.0-desktop.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/auto-multiple-choice.desktop.in-old 2014-02-11 20:25:42.995456713 +0100
-+++ b/auto-multiple-choice.desktop.in 2014-02-11 20:25:54.972456566 +0100
-@@ -10,5 +10,5 @@
- GenericName[fr]=QCM automatique
- Comment=Manage multiple choice questionnaires, with automatic marking from papers' scans
- Comment[fr]=Conception et correction automatique de QCM en LaTeX
--Keywords=multiple;choice;questionnaire;exam;grading;marking;MCQ;AMC
--Keywords[fr]=questionnaire;choix;multiple;examen;correction;QCM;AMC
-+Keywords=multiple;choice;questionnaire;exam;grading;marking;MCQ;AMC;
-+Keywords[fr]=questionnaire;choix;multiple;examen;correction;QCM;AMC;