summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-15 08:26:26 +0000
committerSam James <sam@gentoo.org>2023-02-15 08:26:50 +0000
commite0a0a09c1bb283024c1a10f737eba380a22bcc1f (patch)
tree1b8e6f83a1c2cfb4512c00540bcdbefb4c092240 /app-office/calligra
parentx11-apps/mesa-progs: Rebase patch + Add patch (diff)
downloadgentoo-e0a0a09c1bb283024c1a10f737eba380a22bcc1f.tar.gz
gentoo-e0a0a09c1bb283024c1a10f737eba380a22bcc1f.tar.bz2
gentoo-e0a0a09c1bb283024c1a10f737eba380a22bcc1f.zip
app-office/calligra: fix build w/ clang 16
It's fixed upstream in a very large commit which can't be applied cleanly to 3.2.1-r5. We can drop this workaround upon the next release though. Closes: https://bugs.gentoo.org/883067 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/calligra')
-rw-r--r--app-office/calligra/calligra-3.2.1-r5.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-office/calligra/calligra-3.2.1-r5.ebuild b/app-office/calligra/calligra-3.2.1-r5.ebuild
index 49246e3bca3d..f26074e74960 100644
--- a/app-office/calligra/calligra-3.2.1-r5.ebuild
+++ b/app-office/calligra/calligra-3.2.1-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ ECM_HANDBOOK="forceoptional"
ECM_TEST="forceoptional"
KFMIN=5.88.0
QTMIN=5.15.2
-inherit check-reqs ecm kde.org
+inherit check-reqs ecm flag-o-matic kde.org
DESCRIPTION="KDE Office Suite"
HOMEPAGE="https://calligra.org/"
@@ -144,6 +144,9 @@ src_prepare() {
src_configure() {
local cal_ft myproducts
+ # Uses removed 'register' keyword, drop on next release. bug #883067
+ append-cxxflags -std=c++14
+
# applications
for cal_ft in ${CAL_FTS[@]}; do
use calligra_features_${cal_ft} && myproducts+=( "${cal_ft^^}" )