summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-03 12:44:10 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-03 14:00:05 +0100
commit3ee4419769b637ebcdaf451c1e6b1f9c4020da0a (patch)
treee9961accb7a18774c9ad34f4c8fb87eb383a7540 /app-office
parentdev-python/pypy-exe: Stabilize 7.3.15 x86, #923699 (diff)
downloadgentoo-3ee4419769b637ebcdaf451c1e6b1f9c4020da0a.tar.gz
gentoo-3ee4419769b637ebcdaf451c1e6b1f9c4020da0a.tar.bz2
gentoo-3ee4419769b637ebcdaf451c1e6b1f9c4020da0a.zip
app-office/joplin-desktop: bump to 2.14.11
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/joplin-desktop/Manifest1
-rw-r--r--app-office/joplin-desktop/joplin-desktop-2.14.11.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-office/joplin-desktop/Manifest b/app-office/joplin-desktop/Manifest
index 9916c758c00c..8c3083bc8acb 100644
--- a/app-office/joplin-desktop/Manifest
+++ b/app-office/joplin-desktop/Manifest
@@ -1,3 +1,4 @@
DIST Joplin-2.13.12.AppImage 210948143 BLAKE2B ea2e1f73009b6255cb780e9c19878090ec90c0203a1cf33dc6e0f23feb8e1fe18ce8acaeb48904f6f71a0ec1aa8d6beaeb79be2db5196477ee8c7379fabc8d0d SHA512 6a68967045b31b010d03ac17a855404f77fbe0d403dce2f5740673c135b99536b940880fe2f103199295476ed1ec5e83465b8b0a26ef409cef362c8ef23e2219
DIST Joplin-2.13.13.AppImage 210904202 BLAKE2B cb2496524cfa0510da5046f74f87a59cf830a0a80c643b813d282085bb6620a9455185a4365c2cef53a6009cc160a231e61ad0c07c4520794ffd188d960789c3 SHA512 d2184d84c6d9f3bf10ddb2da1c4f7437ceb8f6fb237989b109e0051bafbd990b42710a277786ffd09826b825e7fc815f3853e9b2388fbf55544f49803d0b9d86
DIST Joplin-2.13.15.AppImage 210896525 BLAKE2B 3474dc12fa083ff4d56e0c64343def5171dd7b739c845c2a3ade562de7ae63d3d79a434611d00b0763f43e2a97281f989128c1fdf5ca5acb64f3e8bdd9cbc7f8 SHA512 d5fc3eee37f506aabb131b14e61ce459602d9c80da61b63ef07a849987cce5ff59af913000ac27baad8e3af637ca6cb28ad4ecaea523b24b4aac1a8b0df76493
+DIST Joplin-2.14.11.AppImage 247754522 BLAKE2B c39b87ca790b41d30c505b1001b75b442790c314cfd1340e2a6c1df7fa9d83505a9664d9fa57f30f7d2dd4dd23e2e04abad3bced978023203e2d9de773aac1a6 SHA512 1f2ed8d9ca6c83d86e09eb039b7d200c926e6ccd02e3db0f1e276640204bf5d6cc2df511b302fcf8b28edcff8f3534b0d52d051439f4275ce1b8f6a55fa5ad78
diff --git a/app-office/joplin-desktop/joplin-desktop-2.14.11.ebuild b/app-office/joplin-desktop/joplin-desktop-2.14.11.ebuild
new file mode 100644
index 000000000000..a9c365263d83
--- /dev/null
+++ b/app-office/joplin-desktop/joplin-desktop-2.14.11.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This is a Electron app (oh my) and the upstream only provides AppImages.
+
+EAPI=8
+
+APPIMAGE="Joplin-${PV}.AppImage"
+
+inherit desktop xdg
+
+DESCRIPTION="Secure note taking and to-do app with synchronization capabilities"
+HOMEPAGE="https://joplinapp.org/
+ https://github.com/laurent22/joplin/"
+SRC_URI="https://github.com/laurent22/joplin/releases/download/v${PV}/${APPIMAGE}"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cp "${DISTDIR}/${APPIMAGE}" "${S}" || die
+
+ cd "${S}" || die # "appimage-extract" unpacks to current directory.
+ chmod +x "${S}/${APPIMAGE}" || die
+ "${S}/${APPIMAGE}" --appimage-extract || die
+}
+
+src_prepare() {
+ # Fix permissions.
+ find "${S}" -type d -exec chmod a+rx {} + || die
+ find "${S}" -type f -exec chmod a+r {} + || die
+
+ default
+}
+
+src_install() {
+ cd "${S}/squashfs-root" || die
+
+ insinto /usr/share
+ doins -r ./usr/share/icons
+
+ local apphome="/opt/${PN}"
+ local toremove=(
+ .DirIcon
+ @joplinapp-desktop.desktop
+ @joplinapp-desktop.png
+ AppRun
+ LICENSE.electron.txt
+ LICENSES.chromium.html
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm64
+ resources/app.asar.unpacked/node_modules/node-notifier
+ usr
+ )
+ rm -f -r "${toremove[@]}" || die
+
+ mkdir -p "${ED}/${apphome}" || die
+ cp -r . "${ED}/${apphome}" || die
+
+ dosym -r "${apphome}/@joplinapp-desktop" "/usr/bin/${PN}"
+ make_desktop_entry "${PN}" Joplin @joplinapp-desktop "Office;" \
+ "StartupWMClass=Joplin\nMimeType=x-scheme-handler/joplin;"
+}