summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-24 14:22:26 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-24 17:43:39 +0200
commit47e85cc5038d9d105aa58a66c38ccf1724ee26bf (patch)
treea841cdde83366c3181614ea2ee2b57f42c66cecc /app-office
parentapp-office/joplin-desktop: drop old 3.0.12 (diff)
downloadgentoo-47e85cc5038d9d105aa58a66c38ccf1724ee26bf.tar.gz
gentoo-47e85cc5038d9d105aa58a66c38ccf1724ee26bf.tar.bz2
gentoo-47e85cc5038d9d105aa58a66c38ccf1724ee26bf.zip
app-office/joplin-desktop: bump to 3.0.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/joplin-desktop/Manifest1
-rw-r--r--app-office/joplin-desktop/joplin-desktop-3.0.15.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-office/joplin-desktop/Manifest b/app-office/joplin-desktop/Manifest
index f38717c1d524..e26ce944f1f7 100644
--- a/app-office/joplin-desktop/Manifest
+++ b/app-office/joplin-desktop/Manifest
@@ -1,2 +1,3 @@
DIST Joplin-3.0.13.AppImage 239287815 BLAKE2B 0766d60d974698758872c046046b133629583f06cbc3b4fd33d0f4886bc7eba3188a47ec5205b5396dbe7a4bd537c0c9ec9677ace97a03dc0d0087c540bb1dd9 SHA512 f96ca6dfb18a5794236e16fd0c0e0c851af2cc20ecfd6095ebbdbf74bd29888726676744196927f84f5f03518ad2bb3960bb599c149b480b8a2383e936eb4a30
DIST Joplin-3.0.14.AppImage 239287839 BLAKE2B 3aedf934239f2f20da76a7a59e1e11587a7ad7aadbab3718be79d62100c5b98560c9856a16948dea4f0f2f2a1c3e412dadb27d5c88b5f4c23be922775d611b08 SHA512 27e44ae52c9954f5ce1b2cb96e2287725d1371262c645eb73953cbe4de9e1ce875211842a666153b8e4820e3117f91249f2e9ee7770e24b15383a269ce6829ce
+DIST Joplin-3.0.15.AppImage 239276178 BLAKE2B 749095fd4e89a876155b4f83b87ec461df3054d75b81eb13c62383d6ba43fb7e846f9d48a855a14d6a4b8cb26e6660e28d08dca5e5f9a7191d21c29982ad250e SHA512 ace649b9e4c4039e0e85f6fee6a9e39b850601ae493a4b98451f651ca24fd9177fad89b5b81cb116b3b41c82b7ccd76f870f0293ca8398d20cdb74e992b9b0c8
diff --git a/app-office/joplin-desktop/joplin-desktop-3.0.15.ebuild b/app-office/joplin-desktop/joplin-desktop-3.0.15.ebuild
new file mode 100644
index 000000000000..a9c365263d83
--- /dev/null
+++ b/app-office/joplin-desktop/joplin-desktop-3.0.15.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This is a Electron app (oh my) and the upstream only provides AppImages.
+
+EAPI=8
+
+APPIMAGE="Joplin-${PV}.AppImage"
+
+inherit desktop xdg
+
+DESCRIPTION="Secure note taking and to-do app with synchronization capabilities"
+HOMEPAGE="https://joplinapp.org/
+ https://github.com/laurent22/joplin/"
+SRC_URI="https://github.com/laurent22/joplin/releases/download/v${PV}/${APPIMAGE}"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libcanberra[gtk3]
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cp "${DISTDIR}/${APPIMAGE}" "${S}" || die
+
+ cd "${S}" || die # "appimage-extract" unpacks to current directory.
+ chmod +x "${S}/${APPIMAGE}" || die
+ "${S}/${APPIMAGE}" --appimage-extract || die
+}
+
+src_prepare() {
+ # Fix permissions.
+ find "${S}" -type d -exec chmod a+rx {} + || die
+ find "${S}" -type f -exec chmod a+r {} + || die
+
+ default
+}
+
+src_install() {
+ cd "${S}/squashfs-root" || die
+
+ insinto /usr/share
+ doins -r ./usr/share/icons
+
+ local apphome="/opt/${PN}"
+ local toremove=(
+ .DirIcon
+ @joplinapp-desktop.desktop
+ @joplinapp-desktop.png
+ AppRun
+ LICENSE.electron.txt
+ LICENSES.chromium.html
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm64
+ resources/app.asar.unpacked/node_modules/node-notifier
+ usr
+ )
+ rm -f -r "${toremove[@]}" || die
+
+ mkdir -p "${ED}/${apphome}" || die
+ cp -r . "${ED}/${apphome}" || die
+
+ dosym -r "${apphome}/@joplinapp-desktop" "/usr/bin/${PN}"
+ make_desktop_entry "${PN}" Joplin @joplinapp-desktop "Office;" \
+ "StartupWMClass=Joplin\nMimeType=x-scheme-handler/joplin;"
+}