summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /app-portage/g-octave
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-portage/g-octave')
-rw-r--r--app-portage/g-octave/g-octave-0.4.1-r6.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-portage/g-octave/g-octave-0.4.1-r6.ebuild b/app-portage/g-octave/g-octave-0.4.1-r6.ebuild
index 88b2d88d7950..dbf8ea63a922 100644
--- a/app-portage/g-octave/g-octave-0.4.1-r6.ebuild
+++ b/app-portage/g-octave/g-octave-0.4.1-r6.ebuild
@@ -39,13 +39,13 @@ python_prepare_all() {
python_compile_all() {
if use doc; then
- emake -C docs html || die 'failed to compile the documentation.'
+ emake -C docs html
fi
}
python_install_all() {
local HTML_DOCS=( ${PN}.html )
- doman ${PN}.1 || die 'doman failed.'
+ doman ${PN}.1
if use doc; then
mv docs/_build/{html,sphinx} || die 'mv failed.'
HTML_DOCS+=( docs/_build/sphinx )