summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-03 16:43:51 +0100
committerSam James <sam@gentoo.org>2023-10-03 16:44:35 +0100
commitc162ce62447fec711a28ecf1434879256c8aea6a (patch)
treef34662131752b84e7a860095e40b5b9c1d077fe6 /app-portage/gentoolkit
parentapp-portage/getuto: Stabilize 1.9 sparc, #915093 (diff)
downloadgentoo-c162ce62447fec711a28ecf1434879256c8aea6a.tar.gz
gentoo-c162ce62447fec711a28ecf1434879256c8aea6a.tar.bz2
gentoo-c162ce62447fec711a28ecf1434879256c8aea6a.zip
app-portage/gentoolkit: add 0.6.2
Bug: https://bugs.gentoo.org/900224 Closes: https://bugs.gentoo.org/369581 Closes: https://bugs.gentoo.org/382009 Closes: https://bugs.gentoo.org/576224 Closes: https://bugs.gentoo.org/709816 Closes: https://bugs.gentoo.org/861116 Closes: https://bugs.gentoo.org/877519 Closes: https://bugs.gentoo.org/902551 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/gentoolkit')
-rw-r--r--app-portage/gentoolkit/Manifest1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/app-portage/gentoolkit/Manifest b/app-portage/gentoolkit/Manifest
index 3b2e5a268698..dfcc1e98765b 100644
--- a/app-portage/gentoolkit/Manifest
+++ b/app-portage/gentoolkit/Manifest
@@ -1 +1,2 @@
DIST gentoolkit-0.6.1.tar.gz 3195781 BLAKE2B 27e370de77586b375dc70caa1abba4c2bc4207e8f08e0a7ea2953097135506949db71ff9102a0ead198e4dea425440c57b94ac7a811ca2d5e0016fc7e234bb0d SHA512 1ffc466b69a9c53f1bbd40f6f4d1eb33d5f0f4287bb65ba1a7b1b2675ad61ecffa55ed9fda7c1ae8148744f0a77e224315eb1903dfd61a2a3dab1600fc672d2d
+DIST gentoolkit-0.6.2.tar.bz2 3186974 BLAKE2B 48f388962e70842b7959467b7697b98121ee2a27bca6e2fc2ebb69782ece1df9b63b4451e19ebacf5a627a9c6feb17f7af395229d2eb870d8bbde1da80262593 SHA512 a1c9157758453f214e6131237df2bc91c49c28a4411ecbb0f74768ae0dd7c4fe8272cfc354a424f6acc8cc322d4eaa35ef98147fe749bc41cb680bb3acfdc2ac
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.2.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.2.ebuild
new file mode 100644
index 000000000000..d4977cdb0e83
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.6.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="xml(+),threads(+)"
+
+inherit distutils-r1 tmpfiles
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoolkit.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoolkit.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+# Need newer Portage for eclean-pkg API, bug #900224
+DEPEND="
+ >=sys-apps/portage-3.0.52[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ app-alternatives/awk
+ sys-apps/gentoo-functions
+"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ python_setup
+ echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ VERSION="${PVR}" "${PYTHON}" setup.py set_version
+ distutils-r1_python_prepare_all
+
+ if use prefix-guest ; then
+ # use correct repo name, bug #632223
+ sed -i \
+ -e "/load_profile_data/s/repo='gentoo'/repo='gentoo_prefix'/" \
+ pym/gentoolkit/profile.py || die
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process revdep-rebuild.conf
+
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "For further information on gentoolkit, please read the gentoolkit"
+ elog "guide: https://wiki.gentoo.org/wiki/Gentoolkit"
+ elog
+ elog "Another alternative to equery is app-portage/portage-utils"
+ elog
+ elog "Additional tools that may be of interest:"
+ elog
+ elog " app-admin/eclean-kernel"
+ elog " app-portage/diffmask"
+ elog " app-portage/flaggie"
+ elog " app-portage/portpeek"
+ elog " app-portage/smart-live-rebuild"
+ fi
+}