summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-12 21:46:02 +0000
committerSam James <sam@gentoo.org>2024-03-12 21:46:25 +0000
commitd129a341c240c68effcb2a03399ea52f36116aea (patch)
tree6441d38e040c73232be88f6558b519d49c7acd4c /app-portage/gentoolkit
parentdev-python/tree-sitter: Stabilize 0.20.4 arm64, #926585 (diff)
downloadgentoo-d129a341c240c68effcb2a03399ea52f36116aea.tar.gz
gentoo-d129a341c240c68effcb2a03399ea52f36116aea.tar.bz2
gentoo-d129a341c240c68effcb2a03399ea52f36116aea.zip
app-portage/gentoolkit: adapt live to new pytest dep + build system option
Closes: https://bugs.gentoo.org/926427 Co-authored-by: Greg Kubaryk <greg.kubaryk@gmail.com> Signed-off-by: Greg Kubaryk <greg.kubaryk@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/gentoolkit')
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 551b618d223a..5eb3d884baf5 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -22,6 +22,8 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
LICENSE="GPL-2"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+IUSE="test"
+RESTRICT="!test? ( test )"
# Need newer Portage for eclean-pkg API, bug #900224
DEPEND="
@@ -44,6 +46,9 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/setuptools[${PYTHON_USEDEP}]
' python3_12)
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
"
src_prepare() {
@@ -64,6 +69,7 @@ src_configure() {
my_src_configure() {
local emesonargs=(
-Dcode-only=${code_only}
+ $(meson_use test tests)
-Deprefix="${EPREFIX}"
-Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
)