summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-05-17 20:15:27 +0200
committerDaniel Pielmeier <billie@gentoo.org>2018-05-17 20:15:27 +0200
commit86df3509ac4bd2b36caf5fed9aada6a34facd57b (patch)
tree79610014fef6e441350ece380f21647dc808a29d /app-portage/pfl
parentdev-db/mariadb-connector-c: Version bump for 3.0.4 and 9999 (diff)
downloadgentoo-86df3509ac4bd2b36caf5fed9aada6a34facd57b.tar.gz
gentoo-86df3509ac4bd2b36caf5fed9aada6a34facd57b.tar.bz2
gentoo-86df3509ac4bd2b36caf5fed9aada6a34facd57b.zip
app-portage/pfl: Fix bug #655538.
Thanks to Thomas Deutschmann for the report. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-portage/pfl')
-rw-r--r--app-portage/pfl/pfl-3.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-portage/pfl/pfl-3.0-r1.ebuild b/app-portage/pfl/pfl-3.0-r1.ebuild
new file mode 100644
index 000000000000..519afebf7bc5
--- /dev/null
+++ b/app-portage/pfl/pfl-3.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="http://files.portagefilelist.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-misc/curl
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )
+ >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT%/}/var/lib/${PN}/pfl.info" || die
+ chown -R 0:portage "${EROOT%/}/var/lib/${PN}" || die
+ chmod 775 "${EROOT%/}/var/lib/${PN}" || die
+ fi
+}