summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-12-21 11:23:54 +0100
committerFabian Groffen <grobian@gentoo.org>2021-12-21 11:25:33 +0100
commit7e74e1d6c4bf1db571db1cec13356ffbe10ba56f (patch)
treec4006b97ccdf368b08a02151916765233157fd59 /app-portage
parentmail-mta/postfix: bump to 3.7_pre20211217 (diff)
downloadgentoo-7e74e1d6c4bf1db571db1cec13356ffbe10ba56f.tar.gz
gentoo-7e74e1d6c4bf1db571db1cec13356ffbe10ba56f.tar.bz2
gentoo-7e74e1d6c4bf1db571db1cec13356ffbe10ba56f.zip
app-portage/portage-utils-0.93: version bump
Closes: https://bugs.gentoo.org/815622 Closes: https://bugs.gentoo.org/816033 Closes: https://bugs.gentoo.org/816060 Closes: https://bugs.gentoo.org/829579 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/portage-utils/Manifest1
-rw-r--r--app-portage/portage-utils/portage-utils-0.93.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index af51126607d7..674ff0f31b74 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1,3 +1,4 @@
DIST portage-utils-0.90.1.tar.xz 1779252 BLAKE2B 27c94694cab84970c0c92e835b9039d9420fbfa20f9f2e03f4f53d118df4dc243cddce33994095a3e41bd1027a42c9c29cda65cb7cf4f45279a028b21555f4f8 SHA512 67290a69ad6ac40da3ce0f41d2630096690e69bb97a1428af921ccc582dcfbf903bbf98259f68afdbe9e96aef81672ea3352a9266a649e75f99acec7fa00cd8a
DIST portage-utils-0.90.tar.xz 1776636 BLAKE2B bbacc05aa97c77705ae4fbdb5efde5f1d49a99ac8ed259e026c9a997f43a86551b3a10a397e0c5f1da161d2c0d88afe88e22870705ca39d911c4a98ad13f4928 SHA512 2077061dd7dfd444d4ad38faf5a87aa44392d7747f71d7283b5e2775ce3d714773cd642ea085aea3dd34a715f2c446d42fd64ba42fa99e716e8d843aae3d9682
DIST portage-utils-0.92.tar.xz 1819676 BLAKE2B 01798e3984745140bca1bcc1eda5c2aea7c517bee2656acfe1bd810fc8088ddcb474f2c64fee6832c5e1699e2ec8ad5a9c6d5afba8a2e2b6f1861d49fbf7fcb7 SHA512 7d36263c9c242c8e82786fa12e171a3f396f65520acb8caa91516862615bd71241699ab6c2232122f7009875aa0a10b06b614a842d45afc86e599b39711e12b3
+DIST portage-utils-0.93.tar.xz 1795964 BLAKE2B 496bed1cbe53c309ceda3eed7b0c343bbf428cc9e8871ff52759f754c5f1d4a834cd648a6ea25b10e7e043077b5a65e40eeebe9101b04f5e5920665aadec822c SHA512 23e85b358fd79c59474aab752fc259e825e90c2b0dd8885cfada79caf59fe71425135e0b6177fcb857e53f1644d159f2e42f1d9116d26757822eb8e6b3ce9989
diff --git a/app-portage/portage-utils/portage-utils-0.93.ebuild b/app-portage/portage-utils/portage-utils-0.93.ebuild
new file mode 100644
index 000000000000..f11ea5afcccd
--- /dev/null
+++ b/app-portage/portage-utils/portage-utils-0.93.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small and fast Portage helper tools written in C"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls static openmp +qmanifest +qtegrity"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage-utils.git"
+else
+ SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+RDEPEND="
+ qmanifest? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ static? (
+ app-crypt/libb2:=[static-libs]
+ dev-libs/openssl:0=[static-libs]
+ sys-libs/zlib:=[static-libs]
+ app-crypt/gpgme:=[static-libs]
+ )
+ !static? (
+ app-crypt/libb2:=
+ dev-libs/openssl:0=
+ sys-libs/zlib:=
+ app-crypt/gpgme:=
+ )
+ )
+ qtegrity? (
+ openmp? (
+ || (
+ >=sys-devel/gcc-4.2:*[openmp]
+ sys-devel/clang-runtime:*[openmp]
+ )
+ )
+ static? (
+ dev-libs/openssl:0=[static-libs]
+ )
+ !static? (
+ dev-libs/openssl:0=
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --with-eprefix="${EPREFIX}" \
+ $(use_enable qmanifest) \
+ $(use_enable qtegrity) \
+ $(use_enable openmp) \
+ $(use_enable static)
+}