summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-28 09:35:06 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-02-28 09:35:06 +0100
commit833b47a00d790886c4c99c8e89b810ee3ca827a3 (patch)
tree68e3a9c2b9aa8a101e8874b46a55ffa5889d02b2 /app-portage
parentsys-devel/qbe: drop 1.0, 1.1 (diff)
downloadgentoo-833b47a00d790886c4c99c8e89b810ee3ca827a3.tar.gz
gentoo-833b47a00d790886c4c99c8e89b810ee3ca827a3.tar.bz2
gentoo-833b47a00d790886c4c99c8e89b810ee3ca827a3.zip
app-portage/command-not-found: add 0.0.3
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/command-not-found/Manifest1
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
index 38833a3443ee..be8335b60930 100644
--- a/app-portage/command-not-found/Manifest
+++ b/app-portage/command-not-found/Manifest
@@ -1 +1,2 @@
DIST command-not-found-0.0.2.tar.gz 9039 BLAKE2B 9781ce588e3e90868dc35745d5f4b24586dd365a0bd2a37a15d973e942ebbd0710675268fe3875be621be51ee7e4b9800865de3d99d58927588d2f05cfe6b789 SHA512 b2b81b754d96364e58d8f71d7024c2c4bc635aff7bd17df4bbc14791f9d7cbd266b2d4ab369ccaaed7b4aca5bb41622c3ce5d7a81795221c5dae3bed001447e4
+DIST command-not-found-0.0.3.tar.gz 9534 BLAKE2B 6505e2de7c093b1ac1e4b056addbab9770bd9fedced12b54f454cd56be29d162ef7f14eea91c855aaf95249bb75af7fe36ca079646c5ca9f8aa8580d5036f796 SHA512 e36309f0e609b7fb607abeca79411d6c998f6c6c7f5769b0a0e72e0e44e4b90af550b5df0b22b94d8151751728b0ef0206ff13d1dd5d0262538c28c563f4b5e6
diff --git a/app-portage/command-not-found/command-not-found-0.0.3.ebuild b/app-portage/command-not-found/command-not-found-0.0.3.ebuild
new file mode 100644
index 000000000000..b0007e526a58
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "command-not-found is automatically setup with bash, to use it with zsh add"
+ elog " \"source /etc/bash/bashrc.d/command-not-found.sh\""
+ elog "anywhere in your /etc/zsh/zshrc or ~/.zshrc"
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}