summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-25 04:47:13 +0100
committerSam James <sam@gentoo.org>2023-04-25 04:48:52 +0100
commita603072e646d22c72ce5d8a432d8bd271a6c4b63 (patch)
tree831ed6d6bad7bc4c421199c2ee68c54ad78c68ee /app-portage
parentapp-text/build-docbook-catalog: add 2.4 (diff)
downloadgentoo-a603072e646d22c72ce5d8a432d8bd271a6c4b63.tar.gz
gentoo-a603072e646d22c72ce5d8a432d8bd271a6c4b63.tar.bz2
gentoo-a603072e646d22c72ce5d8a432d8bd271a6c4b63.zip
app-portage/tatt: add 0.11
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/tatt/Manifest1
-rw-r--r--app-portage/tatt/tatt-0.11.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/tatt/Manifest b/app-portage/tatt/Manifest
index 594069d16a4b..536e70545fd4 100644
--- a/app-portage/tatt/Manifest
+++ b/app-portage/tatt/Manifest
@@ -1 +1,2 @@
DIST tatt-0.10.tar.gz 22675 BLAKE2B 4272cd0bf65a2181ba70d12fe8ca593403d7217aebf2f4dffd2f69397e686c79bc93ec70c756f1e94c548ed2acd8af7470c022611c16b5f3571af860aeca4b9c SHA512 1993f597e92b0b1f004e492aa164d7de6cf6776285850e5245f3328de0396c54cfc58943c767afe1fd1c49a771a1f33c65b6bed3c7d164223767567c05e12af1
+DIST tatt-0.11.tar.gz 22690 BLAKE2B becafd764b570acf5e96975662edefa472a02c2a671830419a4784337c3d898caa97f04a0cc7b30c916f9cf80b49655b4028f5322d82b602176f236997751aa1 SHA512 a4b34458d07187b830b84547cf4ba99171cbd6fde97498a458eff58921a65077c23a89fe5e6292b0d7042149ccba90b6d85cf02c57f5c4ece6d3e89943e16442
diff --git a/app-portage/tatt/tatt-0.11.ebuild b/app-portage/tatt/tatt-0.11.ebuild
new file mode 100644
index 000000000000..f59ad81ef5a5
--- /dev/null
+++ b/app-portage/tatt/tatt-0.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Arch testing tool"
+HOMEPAGE="https://github.com/gentoo/tatt"
+SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit[${PYTHON_USEDEP}]
+ app-portage/nattka[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-client/pybugz
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}