summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2021-11-14 19:31:56 +0100
committerStephan Hartmann <sultan@gentoo.org>2021-11-14 19:32:34 +0100
commit8c82b288ee7e68b6b7e949f06073a349af8b8c72 (patch)
tree55d0f5093774c0322bacf63a3d16207374f2b020 /app-shells/heirloom-sh
parentnet-wireless/bluez: restore dbus slot-operator (diff)
downloadgentoo-8c82b288ee7e68b6b7e949f06073a349af8b8c72.tar.gz
gentoo-8c82b288ee7e68b6b7e949f06073a349af8b8c72.tar.bz2
gentoo-8c82b288ee7e68b6b7e949f06073a349af8b8c72.zip
app-shells/heirloom-sh: fix building with glibc-2.34, EAPI 8
Bug: https://bugs.gentoo.org/806344 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
Diffstat (limited to 'app-shells/heirloom-sh')
-rw-r--r--app-shells/heirloom-sh/files/heirloom-sh-glibc-2.34.patch18
-rw-r--r--app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild10
2 files changed, 25 insertions, 3 deletions
diff --git a/app-shells/heirloom-sh/files/heirloom-sh-glibc-2.34.patch b/app-shells/heirloom-sh/files/heirloom-sh-glibc-2.34.patch
new file mode 100644
index 000000000000..35cb56552697
--- /dev/null
+++ b/app-shells/heirloom-sh/files/heirloom-sh-glibc-2.34.patch
@@ -0,0 +1,18 @@
+--- a/fault.c
++++ b/fault.c
+@@ -43,6 +43,15 @@
+ #include <errno.h>
+ #include <string.h>
+
++#if __GLIBC__ >= 2
++# undef SIGSTKSZ
++# if defined __ia64__
++# define SIGSTKSZ 262144
++# else
++# define SIGSTKSZ 65536
++# endif
++#endif
++
+ static void (*psig0_func)() = SIG_ERR; /* previous signal handler for signal 0 */
+ static char sigsegv_stack[SIGSTKSZ];
+
diff --git a/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
index 6e939fa84091..a67c4acb2d51 100644
--- a/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
+++ b/app-shells/heirloom-sh/heirloom-sh-050706-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit flag-o-matic toolchain-funcs
-# slightly broken
+# no tests available
RESTRICT="test"
DESCRIPTION="Heirloom Bourne Shell, derived from OpenSolaris code SVR4/SVID3"
@@ -16,6 +16,10 @@ LICENSE="CDDL"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+PATCHES=(
+ "${FILESDIR}/${PN}-glibc-2.34.patch"
+)
+
src_compile() {
append-cppflags -D_GNU_SOURCE
emake \