summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-22 16:24:05 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-11-22 16:24:16 -0800
commit3b917ff2d4fe6e2f8d468b51c15998cc904ebd6a (patch)
tree8ccdf62e8051f6f9651ede43b177f63312ecca23 /app-shells/ksh
parentapp-shells/ksh: sync live ebuild (diff)
downloadgentoo-3b917ff2d4fe6e2f8d468b51c15998cc904ebd6a.tar.gz
gentoo-3b917ff2d4fe6e2f8d468b51c15998cc904ebd6a.tar.bz2
gentoo-3b917ff2d4fe6e2f8d468b51c15998cc904ebd6a.zip
app-shells/ksh: add 1.0.4
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells/ksh')
-rw-r--r--app-shells/ksh/Manifest1
-rw-r--r--app-shells/ksh/ksh-1.0.4.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index a9111f06f4fe..1a0148a5cbcf 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1 +1,2 @@
DIST ksh-v1.0.3.tar.gz 2110771 BLAKE2B 4316c78f7889fb2e4630a83dd0f1c5c4c4b418a822e8f7d3d9415a83bbef6e993cbd21b4842c7f56cd8647305c4bdddc04562b8788f2ee6e14698a9cb090f386 SHA512 9d6e664bc6c8d102ba09e692d057b9546b07ba3ecb060449df6648e7c99f8dfd670401e6fcf34f6f3de13338a3c31c09596344931ccfdf4cd4e49eabdf005c23
+DIST ksh-v1.0.4.tar.gz 2127036 BLAKE2B c3bd7f8d8c86e8bf4f7482c99890f025365334b7ab826261b03f9a2f6bf72b4112ba0cec09c7d5388cbba4541a4e99a24e3b95a98e386b941a39f549c5c21525 SHA512 ca6ff4625a48a991d07a34c8d28656c131124e6cccbb495d8fbc2922db9f94a83c1df2be17a7fa7aa39ce5b9243573b0b806eef87d11c5a2936e7af564d2f5e6
diff --git a/app-shells/ksh/ksh-1.0.4.ebuild b/app-shells/ksh/ksh-1.0.4.ebuild
new file mode 100644
index 000000000000..dd729029724d
--- /dev/null
+++ b/app-shells/ksh/ksh-1.0.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ksh93/ksh"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ MY_PV=$(ver_rs 3 - 4 .)
+ SRC_URI="https://github.com/ksh93/${PN}/archive/v${MY_PV}/ksh-v${MY_PV}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+DESCRIPTION="The Original ATT Korn Shell"
+HOMEPAGE="http://www.kornshell.com/"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+
+src_prepare() {
+ default
+
+ # disable register for debugging
+ sed -i 1i"#define register" src/lib/libast/include/ast.h || die
+}
+
+src_compile() {
+ local extraflags=(
+ "-Wno-unknown-pragmas"
+ "-Wno-missing-braces"
+ "-Wno-unused-result"
+ "-Wno-return-type"
+ "-Wno-int-to-pointer-cast"
+ "-Wno-parentheses"
+ "-Wno-unused"
+ "-Wno-unused-but-set-variable"
+ "-Wno-cpp"
+ "-Wno-maybe-uninitialized"
+ "-Wno-lto-type-mismatch"
+ "-Wno-error=int-conversion"
+ "-Wno-int-conversion"
+ "-P"
+ )
+ append-cflags $(test-flags-CC ${extraflags[@]})
+ filter-flags '-fdiagnostics-color=always' # https://github.com/ksh93/ksh/issues/379
+ export CCFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ tc-export AR CC LD NM
+
+ sh bin/package make SHELL="${BROOT}"/bin/sh || die
+}
+
+src_test() {
+ # test tries to catch IO error
+ addwrite /proc/self/mem
+
+ # arith.sh uses A for tests
+ unset A
+
+ sh bin/shtests --compile || die
+}
+
+src_install() {
+ local myhost="$(sh bin/package host)"
+ cd "arch/${myhost}" || die
+
+ into /
+ dobin bin/ksh
+ dosym ksh /bin/rksh
+
+ newman man/man1/sh.1 ksh.1
+}