summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-09-10 15:58:22 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-09-10 15:58:59 +0700
commitf48aa6a9377f1fc264859169404b8a47e1e3543b (patch)
treec6532c2fc3416b7436fdc6b37d5c44c8f453f132 /app-text/crqt-ng
parentmail-filter/courier-pythonfilter: properly install config files (diff)
downloadgentoo-f48aa6a9377f1fc264859169404b8a47e1e3543b.tar.gz
gentoo-f48aa6a9377f1fc264859169404b8a47e1e3543b.tar.bz2
gentoo-f48aa6a9377f1fc264859169404b8a47e1e3543b.zip
app-text/crqt-ng: Add the Qt6 version
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/crqt-ng')
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.14-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/crqt-ng/crqt-ng-1.0.14-r1.ebuild b/app-text/crqt-ng/crqt-ng-1.0.14-r1.ebuild
new file mode 100644
index 000000000000..0c8500144809
--- /dev/null
+++ b/app-text/crqt-ng/crqt-ng-1.0.14-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="bg cs hu nl ru uk"
+inherit cmake plocale xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+qt6 +gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ qt6? (
+ dev-qt/qtbase:6[gui,widgets]
+ )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+RDEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
+ qt6? (
+ dev-qt/qttools:6[linguist]
+ )
+ !qt6? (
+ dev-qt/linguist-tools:5
+ )"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_environment_reset
+
+ # locales
+ plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
+ sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
+ -i "${S}"/src/CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=
+ if use qt6; then
+ mycmakeargs=(-DUSE_QT=QT6)
+ else
+ (-DUSE_QT=QT5)
+ fi
+ cmake_src_configure
+}