summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2018-07-04 22:36:20 +0300
committerMichał Górny <mgorny@gentoo.org>2018-07-26 10:35:09 +0200
commitf3a064e1a7d2f6f526ebdff215a981387a7d652d (patch)
treee262e242c4fcfd7407d84c3420fdd7fe73b7f09e /app-text/docbook-dsssl-stylesheets
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.144,4.9.115,4.14.5... (diff)
downloadgentoo-f3a064e1a7d2f6f526ebdff215a981387a7d652d.tar.gz
gentoo-f3a064e1a7d2f6f526ebdff215a981387a7d652d.tar.bz2
gentoo-f3a064e1a7d2f6f526ebdff215a981387a7d652d.zip
app-text/docbook-dsssl-stylesheets: install missing files, cleanup
Due to Gentoo-originated poorly written Makefile not all required files were installed, which caused tools looking for them to fail, e.g. Gentoo bug 606768. Also one file that belong to another package was installed: dtds/decls/docbook.dcl is a part of docbook-sgml-dtd. Replace custom Makefile with a series of doins commands. Also remove dirty, ugly symlink hack to workaround Gentoo bug 15026. Current stable libgcrypt doesn't use docbook-dssl-stylesheets for docs. Bug: https://bugs.gentoo.org/606768 Bug: https://bugs.gentoo.org/15026 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-text/docbook-dsssl-stylesheets')
-rw-r--r--app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r3.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r3.ebuild b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r3.ebuild
new file mode 100644
index 000000000000..2cf6e40311d1
--- /dev/null
+++ b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# EAPI=6 is blocked by Gentoo bug 497052.
+EAPI=5
+
+MY_P=${P/-stylesheets/}
+
+inherit sgml-catalog
+
+DESCRIPTION="DSSSL Stylesheets for DocBook"
+HOMEPAGE="https://github.com/docbook/wiki/wiki"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ app-text/sgml-common
+ app-text/docbook-sgml-dtd:3.0
+"
+
+DOCS=( BUGS ChangeLog README RELEASE-NOTES.txt WhatsNew )
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ local dsssldir CATALOG_DIR=usr/share/sgml/docbook/dsssl-stylesheets-${PV}
+
+ dobin bin/collateindex.pl
+
+ insinto ${CATALOG_DIR}
+ doins catalog VERSION
+
+ insinto ${CATALOG_DIR}/common
+ doins common/*.{dsl,ent}
+
+ insinto ${CATALOG_DIR}/images
+ doins images/*.gif
+
+ for dsssldir in html lib olink print; do
+ insinto ${CATALOG_DIR}/${dsssldir}
+ doins ${dsssldir}/*.dsl
+ done
+
+ for dsssldir in dbdsssl html imagelib olink; do
+ insinto ${CATALOG_DIR}/dtds/${dsssldir}
+ doins dtds/${dsssldir}/*.dtd
+ done
+
+ insinto ${CATALOG_DIR}/dtds/html
+ doins dtds/html/*.{dcl,gml}
+
+ dodoc "${DOCS[@]}"
+}
+
+sgml-catalog_cat_include \
+ "/etc/sgml/dsssl-docbook-stylesheets.cat" \
+ "/usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog"
+
+sgml-catalog_cat_include \
+ "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/dsssl-docbook-stylesheets.cat"