summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-11 04:40:55 +0000
committerSam James <sam@gentoo.org>2023-02-11 04:53:22 +0000
commit9370b4ba6eff5393e34e8ac68c1748f13d3d76ba (patch)
treed0d1ebd479865988eecef471eced05faed7a2a6e /app-text/html-xml-utils/html-xml-utils-8.5.ebuild
parentnet-irc/scrollz: add github upstream metadata (diff)
downloadgentoo-9370b4ba6eff5393e34e8ac68c1748f13d3d76ba.tar.gz
gentoo-9370b4ba6eff5393e34e8ac68c1748f13d3d76ba.tar.bz2
gentoo-9370b4ba6eff5393e34e8ac68c1748f13d3d76ba.zip
app-text/html-xml-utils: add 8.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/html-xml-utils/html-xml-utils-8.5.ebuild')
-rw-r--r--app-text/html-xml-utils/html-xml-utils-8.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/html-xml-utils/html-xml-utils-8.5.ebuild b/app-text/html-xml-utils/html-xml-utils-8.5.ebuild
new file mode 100644
index 000000000000..bf51929c322d
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-8.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files"
+HOMEPAGE="https://www.w3.org/Tools/HTML-XML-utils/"
+SRC_URI="https://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+
+LICENSE="W3C"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ net-dns/libidn2:=
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -e "/doc_DATA = COPYING/d" -i Makefile.in || die
+}
+
+src_test() {
+ # Lots of tests lack a shebang and use bashisms
+ emake check SHELL="${BROOT}"/bin/bash
+}