summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-23 20:57:19 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-23 21:19:23 +0100
commita58b3731e753121d653abc77f0820f6f1d30e7db (patch)
tree263a9261262d4b231ea8f9f59a7f46e98ba9450f /app-text/kbibtex
parentapp-editors/kile: add 2.9.93_p20221123, EAPI-8 bump (diff)
downloadgentoo-a58b3731e753121d653abc77f0820f6f1d30e7db.tar.gz
gentoo-a58b3731e753121d653abc77f0820f6f1d30e7db.tar.bz2
gentoo-a58b3731e753121d653abc77f0820f6f1d30e7db.zip
app-text/kbibtex: Backport two upstream fixes, update EAPI 7 -> 8
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/kbibtex')
-rw-r--r--app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch28
-rw-r--r--app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch28
-rw-r--r--app-text/kbibtex/kbibtex-0.9.2-r1.ebuild84
3 files changed, 140 insertions, 0 deletions
diff --git a/app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch b/app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch
new file mode 100644
index 000000000000..91cc51f9303c
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.9.2-fix-crash-w-newer-Qt.patch
@@ -0,0 +1,28 @@
+From 84b0551eb141b3a7904ceec158d040200c995023 Mon Sep 17 00:00:00 2001
+From: Albert Astals Cid <aacid@kde.org>
+Date: Thu, 8 Apr 2021 22:07:15 +0200
+Subject: [PATCH] Fix crash with newer Qt versions
+
+Assign m_internalModel before calling into
+QSortFilterProxyModel::setSourceModel since that can end up calling filterAcceptsRow
+---
+ src/gui/file/sortfilterfilemodel.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gui/file/sortfilterfilemodel.cpp b/src/gui/file/sortfilterfilemodel.cpp
+index 73707cec..87657aa2 100644
+--- a/src/gui/file/sortfilterfilemodel.cpp
++++ b/src/gui/file/sortfilterfilemodel.cpp
+@@ -40,8 +40,8 @@ SortFilterFileModel::SortFilterFileModel(QObject *parent)
+
+ void SortFilterFileModel::setSourceModel(QAbstractItemModel *model)
+ {
+- QSortFilterProxyModel::setSourceModel(model);
+ m_internalModel = dynamic_cast<FileModel *>(model);
++ QSortFilterProxyModel::setSourceModel(model);
+ }
+
+ FileModel *SortFilterFileModel::fileSourceModel() const
+--
+GitLab
+
diff --git a/app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch b/app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch
new file mode 100644
index 000000000000..fdc42d97810b
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.9.2-fix-creation-w-url-from-user-input.patch
@@ -0,0 +1,28 @@
+From 1153930536abe9f0331acef67dc40b18210eb07e Mon Sep 17 00:00:00 2001
+From: Thomas Fischer <fischer@unix-ag.uni-kl.de>
+Date: Sat, 1 Oct 2022 23:15:52 +0200
+Subject: [PATCH] Fix creation of URL from user input
+
+... when opening a document associated with a bibliographic entry.
+
+BUG: 459150
+---
+ src/parts/part.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/parts/part.cpp b/src/parts/part.cpp
+index 5324647f..9dc35d1c 100644
+--- a/src/parts/part.cpp
++++ b/src/parts/part.cpp
+@@ -914,7 +914,7 @@ void KBibTeXPart::elementViewDocumentMenu(QObject *obj)
+ QString text = static_cast<QAction *>(obj)->data().toString(); ///< only a QAction will be passed along
+
+ /// Guess mime type for url to open
+- QUrl url(text);
++ QUrl url{QUrl::fromUserInput(text)};
+ QMimeType mimeType = FileInfo::mimeTypeForUrl(url);
+ const QString mimeTypeName = mimeType.name();
+ /// Ask KDE subsystem to open url in viewer matching mime type
+--
+GitLab
+
diff --git a/app-text/kbibtex/kbibtex-0.9.2-r1.ebuild b/app-text/kbibtex/kbibtex-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..e8d349aaa433
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-0.9.2-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+KFMIN=5.82.0
+QTMIN=5.15.5
+inherit ecm kde.org optfeature
+
+DESCRIPTION="BibTeX editor to edit bibliographies used with LaTeX"
+HOMEPAGE="https://apps.kde.org/kbibtex/ https://userbase.kde.org/KBibTeX"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/KBibTeX/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="5"
+IUSE="webengine zotero"
+
+RESTRICT="test"
+
+DEPEND="
+ app-text/poppler[qt5]
+ dev-libs/icu:=
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ virtual/tex-base
+ webengine? ( >=dev-qt/qtwebengine-${QTMIN}:5[widgets] )
+ zotero? (
+ >=app-crypt/qca-2.3.0:2[qt5(+)]
+ dev-libs/qoauth:5
+ )
+"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-crash-w-newer-Qt.patch"
+ "${FILESDIR}/${P}-fix-creation-w-url-from-user-input.patch" # KDE-bug 459150
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebKitWidgets=ON
+ $(cmake_use_find_package webengine Qt5WebEngineWidgets)
+ $(cmake_use_find_package zotero Qca-qt5)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "PDF or PostScript document previews" "kde-apps/okular:${SLOT}"
+ fi
+ ecm_pkg_postinst
+}