summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/lv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/lv/files')
-rw-r--r--app-text/lv/files/lv-4.51-gentoo.patch40
-rw-r--r--app-text/lv/files/lv-4.51-tinfo.patch22
-rw-r--r--app-text/lv/files/lv-4.51-xz.diff43
3 files changed, 105 insertions, 0 deletions
diff --git a/app-text/lv/files/lv-4.51-gentoo.patch b/app-text/lv/files/lv-4.51-gentoo.patch
new file mode 100644
index 000000000000..90acab49fd16
--- /dev/null
+++ b/app-text/lv/files/lv-4.51-gentoo.patch
@@ -0,0 +1,40 @@
+diff -Naur lv451.orig/src/Makefile.in lv451/src/Makefile.in
+--- lv451.orig/src/Makefile.in 2004-01-06 16:22:17.000000000 +0900
++++ lv451/src/Makefile.in 2008-10-08 00:20:13.000000000 +0900
+@@ -25,6 +25,7 @@
+ LDFLAGS=@LDFLAGS@
+ INSTALL=@INSTALL@
+ PERL= @PERL@
++DESTDIR=
+
+ OBJS= itable.o ctable.o uty.o istr.o stream.o file.o guess.o decode.o \
+ encode.o escape.o iso2022.o iso8859.o iso2cn.o iso2jp.o iso2kr.o \
+@@ -64,18 +65,19 @@
+ #
+
+ install::
+- $(INSTALL) -s -m 555 lv $(bindir)
+- if test -f $(bindir)/lgrep; then \
+- /bin/rm -f $(bindir)/lgrep; \
++ if test ! -d $(DESTDIR)$(bindir); then \
++ mkdir -p $(DESTDIR)$(bindir); \
+ fi
+- (cd $(bindir); ln lv lgrep)
+- if test ! -d $(lvlibdir); then \
+- mkdir -p $(lvlibdir); \
++ $(INSTALL) -m 555 lv $(DESTDIR)$(bindir)
++ (cd $(DESTDIR)$(bindir); ln -s lv lgrep)
++ if test ! -d $(DESTDIR)$(lvlibdir); then \
++ mkdir -p $(DESTDIR)$(lvlibdir); \
+ fi
+- $(INSTALL) -m 444 $(srcdir)/../lv.hlp $(lvlibdir)
+- if test -d $(mandir) -a -d $(mandir)/man1; then \
+- $(INSTALL) -m 444 $(srcdir)/../lv.1 $(mandir)/man1; \
++ $(INSTALL) -m 444 $(srcdir)/../lv.hlp $(DESTDIR)$(lvlibdir)
++ if test ! -d $(DESTDIR)$(mandir)/man1; then \
++ mkdir -p $(DESTDIR)$(mandir)/man1; \
+ fi
++ $(INSTALL) -m 444 $(srcdir)/../lv.1 $(DESTDIR)$(mandir)/man1; \
+
+ uninstall::
+ for i in $(bindir)/lv $(bindir)/lgrep $(lvlibdir)/lv.hlp $(mandir)/man1/lv.1; do \
diff --git a/app-text/lv/files/lv-4.51-tinfo.patch b/app-text/lv/files/lv-4.51-tinfo.patch
new file mode 100644
index 000000000000..9c17a92a65ef
--- /dev/null
+++ b/app-text/lv/files/lv-4.51-tinfo.patch
@@ -0,0 +1,22 @@
+diff --git a/src/configure.in b/src/configure.in
+index 7d118de..29833a7 100644
+--- a/src/configure.in
++++ b/src/configure.in
+@@ -24,7 +24,16 @@ AC_ARG_ENABLE(purify,
+ dnl Checks for libraries.
+ AC_DEFINE(UNIX)
+ AC_DEFINE(TERMCAP)
+-AC_CHECK_LIB(terminfo, tgetstr,, [AC_CHECK_LIB(termcap, tgetstr,, [AC_CHECK_LIB(ncurses, tgetstr,, [AC_CHECK_LIB(curses, tgetstr)])])])
++PKG_CHECK_MODULES(
++ CURSES,
++ ncurses,
++ [
++ CPPFLAGS="$CURSES_CFLAGS $CPPFLAGS"
++ LIBS="$CURSES_LIBS $LIBS"
++ ],
++ [
++ AC_CHECK_LIB(terminfo, tgetstr,, [AC_CHECK_LIB(termcap, tgetstr,, [AC_CHECK_LIB(ncurses, tgetstr,, [AC_CHECK_LIB(curses, tgetstr)])])])
++ ])
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/app-text/lv/files/lv-4.51-xz.diff b/app-text/lv/files/lv-4.51-xz.diff
new file mode 100644
index 000000000000..058029b8be28
--- /dev/null
+++ b/app-text/lv/files/lv-4.51-xz.diff
@@ -0,0 +1,43 @@
+--- lv451.orig/index.html
++++ lv451/index.html
+@@ -301,8 +301,11 @@
+ <P>
+ Compressed files that have suffix ``gz'', ``z'', or ``GZ'', ``Z'' are
+ extracted by lv using <I>zcat</I> (1),
+- and ``bz2'' or ``BZ2'' with <I>bzcat</I> (1).
+- Please install <I>zcat</I> and <I>bzcat</I> that can expand all of them.
++ ``bz2'' or ``BZ2'' with <I>bzcat</I> (1).
++ ``lzma'' or ``LZMA'' with <I>lzcat</I> (1).
++ and ``xz'' or ``XZ'' with <I>xzcat</I> (1).
++ Please install <I>zcat</I>, <I>bzcat</I>, <I>lzcat</I> and <I>xzcat</I>
++ that can expand all of them.
+ <P>
+ In case that standard output is not connected to an ordinal terminal
+ but to redirect or pipe-line,
+--- lv451.orig/src/stream.c
++++ lv451/src/stream.c
+@@ -43,6 +43,8 @@
+
+ private byte *gz_filter = "zcat";
+ private byte *bz2_filter = "bzcat";
++private byte *lzma_filter = "lzcat";
++private byte *xz_filter = "xzcat";
+
+ private stream_t *StreamAlloc()
+ {
+@@ -75,10 +77,14 @@
+ filter = gz_filter;
+ else if( !strcmp( "bz2", exts ) || !strcmp( "BZ2", exts ) )
+ filter = bz2_filter;
++ else if( !strcmp( "lzma", exts ) || !strcmp( "LZMA", exts ) )
++ filter = lzma_filter;
++ else if( !strcmp( "xz", exts ) || !strcmp( "XZ", exts ) )
++ filter = xz_filter;
+ }
+ if( NULL != filter ){
+ /*
+- * zcat or bzcat
++ * zcat or bzcat or lzcat or xzcat
+ */
+ if( NULL == (st->fp = (FILE *)tmpfile()) )
+ perror( "temporary file" ), exit( -1 );