summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-22 05:05:19 +0000
committerSam James <sam@gentoo.org>2021-12-22 05:05:19 +0000
commit59a511f3eb46bb4dcc9569513497509699bf1d38 (patch)
tree4751d778bb7e7a8941734659bfccece03565083b /app-text/qpdf
parentapp-text/qpdf: drop 10.0.4, 10.1.0, 10.3.1 (diff)
downloadgentoo-59a511f3eb46bb4dcc9569513497509699bf1d38.tar.gz
gentoo-59a511f3eb46bb4dcc9569513497509699bf1d38.tar.bz2
gentoo-59a511f3eb46bb4dcc9569513497509699bf1d38.zip
app-text/qpdf: add 10.5.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/qpdf')
-rw-r--r--app-text/qpdf/Manifest2
-rw-r--r--app-text/qpdf/qpdf-10.5.0.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index c7ed6bb77b41..22144477787b 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -1,2 +1,4 @@
DIST qpdf-10.3.2.tar.gz 18943834 BLAKE2B 5b4e320ddd663721d8201139842bb09a752347f86c3e33116063b2fff1426aed5ff6e3c581c120771a712a8ed278102e0d41816db207a25dabd84e5b89490d35 SHA512 4e630959abf27d1801e36d0cbd754945ded42ade9299057a6b9a642c7cb2a3f8242e274642f1c33a65b4a5a77562d91dcbe64fd5772d483cbe5edb4a6a389219
DIST qpdf-10.4.0.tar.gz 18942833 BLAKE2B bc984c742bec582b5b67f7a4f4f00bb22a36e8e14d78b8e8848baed0c94489f6920070bc317928c53aca855c252c2fa5de0fba8b64ba16ba37afc2362d6ae7ba SHA512 7a17cc2b3168bb60ac05d01b585d34d94f62e44e309b86635351b2564bc2c3b7846d3a008ae0d6c068bce3b1d9c42d3a3ab40de3f85a1ec4952280cf8321a041
+DIST qpdf-10.5.0-doc.zip 6621139 BLAKE2B 9297946619df67799a450495ead8a980d8e2cfa92556e9eb6ac6f365b80d489bb11a9c5dd95e13df9a8fb013a3f254e89ae1682e8be73799ba0c872dc50075c5 SHA512 75c4eac6e828eb5f8544b4194b775e8258a769aa5e18006b9491d9658981abcd286cd082a233122805e785f283704dccaf2078cd84965ab58ebc6c80fdb4a06f
+DIST qpdf-10.5.0.tar.gz 18362586 BLAKE2B efb0a051df9824c6324ce3c4de7b6f5890a04e0a0e1e08a1086c7b7a7e3d29e01d8b6760eeb36cd5461f5ea8a9ac1e6453711df53b514c223abd3d2a41ae1a93 SHA512 758dd4fd86b79a8b08738abb36685cf4a458dcf70a480efe3207d1148a691cf06a8040c83075ace9c3bbaf372cefe78508df2e52513cc969dca76442ed43775d
diff --git a/app-text/qpdf/qpdf-10.5.0.ebuild b/app-text/qpdf/qpdf-10.5.0.ebuild
new file mode 100644
index 000000000000..d83ec13d06ca
--- /dev/null
+++ b/app-text/qpdf/qpdf-10.5.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="http://qpdf.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qpdf/${P}.tar.gz"
+SRC_URI+=" doc? ( mirror://sourceforge/qpdf/${P}-doc.zip )"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# subslot = libqpdf soname version
+SLOT="0/28"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris"
+IUSE="doc examples gnutls ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0=
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+BDEPEND="dev-lang/perl
+ doc? ( app-arch/unzip )"
+
+DOCS=( ChangeLog README.md TODO )
+
+src_configure() {
+ # Keep an eye on https://qpdf.readthedocs.io/en/stable/packaging.html.
+ local myeconfargs=(
+ --disable-check-autofiles
+
+ --disable-implicit-crypto
+ --enable-crypto-native
+
+ --disable-oss-fuzz
+ $(use_enable test test-compare-images)
+ )
+
+ if use ssl ; then
+ local crypto_provider=openssl
+
+ if use gnutls ; then
+ crypto_provider=gnutls
+ fi
+
+ myeconfargs+=(
+ --with-default-crypto=${crypto_provider}
+ --enable-crypto-${crypto_provider}
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ docompress -x /usr/share/doc/${PF}/singlehtml
+ dodoc -r "${WORKDIR}"/${P}-doc/.
+
+ fi
+
+ if use examples ; then
+ dobin $(find examples/build/.libs -maxdepth 1 -type f -executable || die)
+ fi
+
+ # Completions
+ dobashcomp completions/bash/qpdf
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_qpdf
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}