summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-09 20:18:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-09 20:18:20 +0300
commit05bb91050e2df13e6c0b8bf6083f5e942283a977 (patch)
treeb8dc505dbf4c4464783357c137face2c9ed9a8fa /app-text/rpl/rpl-1.15.2.ebuild
parentdev-python/pythondialog: update SRC_URI & HOMEPAGE (diff)
downloadgentoo-05bb91050e2df13e6c0b8bf6083f5e942283a977.tar.gz
gentoo-05bb91050e2df13e6c0b8bf6083f5e942283a977.tar.bz2
gentoo-05bb91050e2df13e6c0b8bf6083f5e942283a977.zip
app-text/rpl: add 1.15.2, enable py3.11
Closes: https://bugs.gentoo.org/896646 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-text/rpl/rpl-1.15.2.ebuild')
-rw-r--r--app-text/rpl/rpl-1.15.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-text/rpl/rpl-1.15.2.ebuild b/app-text/rpl/rpl-1.15.2.ebuild
new file mode 100644
index 000000000000..902a5491d3c1
--- /dev/null
+++ b/app-text/rpl/rpl-1.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Intelligent recursive search/replace utility"
+HOMEPAGE="http://rpl.sourceforge.net/
+ https://github.com/rrthomas/rpl"
+SRC_URI="
+ https://github.com/rrthomas/rpl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/argparse-manpage[${PYTHON_USEDEP}]
+ sys-apps/help2man[nls]
+"