summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-15 01:58:46 +0000
committerSam James <sam@gentoo.org>2023-02-15 01:58:46 +0000
commite7a43cae248406d2c069e09f0cb83bcd1bf7b397 (patch)
tree7388c77e7d7f7c1481e557cb4ceda3553611e1dc /app-text/xdvik
parentmedia-libs/libsndfile: Stabilize 1.2.0 arm64, #894306 (diff)
downloadgentoo-e7a43cae248406d2c069e09f0cb83bcd1bf7b397.tar.gz
gentoo-e7a43cae248406d2c069e09f0cb83bcd1bf7b397.tar.bz2
gentoo-e7a43cae248406d2c069e09f0cb83bcd1bf7b397.zip
app-text/xdvik: add 22.87.06
Closes: https://bugs.gentoo.org/882733 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/xdvik')
-rw-r--r--app-text/xdvik/Manifest1
-rw-r--r--app-text/xdvik/files/xdvik-22.87.06-configure-clang16.patch51
-rw-r--r--app-text/xdvik/xdvik-22.87.06.ebuild114
3 files changed, 166 insertions, 0 deletions
diff --git a/app-text/xdvik/Manifest b/app-text/xdvik/Manifest
index 5f476a71daf7..df2f7b7bf9c2 100644
--- a/app-text/xdvik/Manifest
+++ b/app-text/xdvik/Manifest
@@ -1 +1,2 @@
DIST xdvik-22.87.03.tar.gz 4760306 BLAKE2B d242696fadf2980cd307d4a172d2af06d98d07b090279440117f869c9a623bcade8745d7a4d3c108c4eafbdeaadefb8d5ba1ea00bdf77d350cbf83c49c2ca0fb SHA512 d4d418d78658f16d4d278e387ed484b291afc8623b00acaf4110e9f123ed76568714ad50f80588373657f412e8fff36f3e76b3e43f69756d46f031c0f2269a88
+DIST xdvik-22.87.06.tar.gz 5922131 BLAKE2B 88821b7642d2d79158f5b49a7d23dad2209750a44d2b75f131d77a5ee326670d2a9cf09246ea9226a386bce429890459625d87df697599529de1bfc32438bf64 SHA512 93fb231f20ef76e170ae954d076ac5421669b3db71e3a96561626736d516f639227e3e502012ba4612fd238172b82f512985c571702d6c0ce078e60a67e5b19f
diff --git a/app-text/xdvik/files/xdvik-22.87.06-configure-clang16.patch b/app-text/xdvik/files/xdvik-22.87.06-configure-clang16.patch
new file mode 100644
index 000000000000..c3b3f0b98bdb
--- /dev/null
+++ b/app-text/xdvik/files/xdvik-22.87.06-configure-clang16.patch
@@ -0,0 +1,51 @@
+https://github.com/TeX-Live/texlive-source/commit/bb307f8bd91c5ea4f191b9c788056470626893b7
+
+From bb307f8bd91c5ea4f191b9c788056470626893b7 Mon Sep 17 00:00:00 2001
+From: Karl Berry <karl@freefriends.org>
+Date: Thu, 2 Feb 2023 22:57:47 +0000
+Subject: [PATCH] avoid implicit wait and exit declarations for C99
+
+git-svn-id: svn://tug.org/texlive/trunk/Build/source@65717 c570f23f-e606-0410-a88d-b1316a301751
+--- a/configure
++++ b/configure
+@@ -16406,6 +16406,9 @@ else $as_nop
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
+ #ifdef HAVE_VFORK_H
+ #include <vfork.h>
+ #endif
+@@ -16427,7 +16430,7 @@ main (void)
+
+ while (wait(&status) != child)
+ ;
+- exit(
++ _exit(
+ /* Was there some problem with vforking? */
+ child < 0
+
+--- a/m4/xdvi-func-setsid-in-fork.m4
++++ b/m4/xdvi-func-setsid-in-fork.m4
+@@ -22,6 +22,9 @@ AC_DEFUN([XDVI_FUNC_SETSID_IN_VFORK],
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
++#ifdef HAVE_SYS_WAIT_H
++#include <sys/wait.h>
++#endif
+ #ifdef HAVE_VFORK_H
+ #include <vfork.h>
+ #endif]],
+@@ -40,7 +43,7 @@ AC_DEFUN([XDVI_FUNC_SETSID_IN_VFORK],
+
+ while (wait(&status) != child)
+ ;
+- exit(
++ _exit(
+ /* Was there some problem with vforking? */
+ child < 0
+
+
diff --git a/app-text/xdvik/xdvik-22.87.06.ebuild b/app-text/xdvik/xdvik-22.87.06.ebuild
new file mode 100644
index 000000000000..37263ea0b5f1
--- /dev/null
+++ b/app-text/xdvik/xdvik-22.87.06.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop elisp-common flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="DVI previewer for X Window System"
+HOMEPAGE="http://xdvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xdvi/${P}.tar.gz"
+S="${WORKDIR}"/${P}/texk/xdvik
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="motif neXt Xaw3d emacs"
+
+DEPEND=">=media-libs/freetype-2.9.1-r2:2
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ emacs? ( >=app-editors/emacs-23.1:* )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ !motif? (
+ neXt? ( x11-libs/neXtaw )
+ !neXt? (
+ Xaw3d? ( x11-libs/libXaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )
+ dev-libs/kpathsea:="
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ !<app-text/texlive-2007"
+BDEPEND="sys-devel/flex
+ app-alternatives/yacc
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Make sure system kpathsea headers are used
+ cd "${WORKDIR}/${P}/texk/kpathsea" || die
+ local i
+ for i in *.h ; do
+ echo "#include_next \"$i\"" > ${i} || die
+ done
+
+ cd "${WORKDIR}/${P}" || die
+ cd "${S}" || die
+ eapply "${FILESDIR}"/${PN}-22.87.06-configure-clang16.patch
+ eautoreconf
+}
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+
+ local toolkit
+ if use motif ; then
+ toolkit="motif"
+ use neXt && ewarn "neXt USE flag ignored (superseded by motif)"
+ use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by motif)"
+ elif use neXt ; then
+ toolkit="neXtaw"
+ use Xaw3d && ewarn "Xaw3d USE flag ignored (superseded by neXt)"
+ elif use Xaw3d ; then
+ toolkit="xaw3d"
+ else
+ toolkit="xaw"
+ fi
+
+ econf \
+ --with-system-freetype2 \
+ --with-system-kpathsea \
+ --with-kpathsea-include="${EPREFIX}"/usr/include/kpathsea \
+ --with-xdvi-x-toolkit="${toolkit}" \
+ --x-includes="${ESYSROOT}"/usr/include \
+ --x-libraries="${ESYSROOT}"/usr/$(get_libdir)
+}
+
+src_compile() {
+ emake kpathsea_dir="${EPREFIX}"/usr/include/kpathsea
+
+ use emacs && elisp-compile xdvi-search.el
+}
+
+src_install() {
+ dodir /usr/share/texmf-dist/dvips/config
+
+ emake DESTDIR="${D}" install
+
+ dosym ../../texmf-dist/xdvi/XDvi /usr/share/X11/app-defaults/XDvi
+
+ dodoc BUGS FAQ README.*
+
+ use emacs && elisp-install tex-utils *.el *.elc
+
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry xdvi "XDVI" xdvik "Graphics;Viewer"
+ echo "MimeType=application/x-dvi;" >> "${ED}"/usr/share/applications/xdvi-"${PN}".desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use emacs; then
+ elog "Add"
+ elog " (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
+ elog " (require 'xdvi-search)"
+ elog "to your ~/.emacs file"
+ fi
+}