summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-11-07 13:48:27 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-11-07 15:51:25 +0100
commit685261c31b2c6bf140a4ad4d3df305f94a858528 (patch)
tree5c35b412e4b717e6a8d5910a46476bf0371543bc /app-text
parentapp-text/openpaperwork-gtk: add 2.2.1 (diff)
downloadgentoo-685261c31b2c6bf140a4ad4d3df305f94a858528.tar.gz
gentoo-685261c31b2c6bf140a4ad4d3df305f94a858528.tar.bz2
gentoo-685261c31b2c6bf140a4ad4d3df305f94a858528.zip
app-text/paperwork-backend: add 2.2.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/paperwork-backend/Manifest1
-rw-r--r--app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/paperwork-backend/Manifest b/app-text/paperwork-backend/Manifest
index 32a41efcb10a..1b3fd1654632 100644
--- a/app-text/paperwork-backend/Manifest
+++ b/app-text/paperwork-backend/Manifest
@@ -1 +1,2 @@
+DIST paperwork-2.2.1.tar.bz2 2529505 BLAKE2B e5545d3fbb5e41d0ddd21a0358fae496d127b30a3f72e1438eef679c520a3152e4db006d9dc42023431907281452931e90aea187c4928309bde7add2d54b5844 SHA512 f96ddf3efe3b5021e612600fa2e3a9c83db7ec78b9637e434facefcc422700be1b67b74231b4738a7762905ac5267f412839ff9d43cb9dcf7f95a5f3d6f7091f
DIST paperwork-backend-2.1.2.tar.gz 1346499 BLAKE2B daf8c6dee97b0bdf814bcf7e9c83a80ab878250994a770f5fa6be4c0b4e23f0def51e22c0a8652a19e9294f3fab0b522b25c2a91c306ad760d568faf76a78610 SHA512 0156baa658a9fe26680bf6d146af3f03b98da307ee1cfaf4803f8b70a2ffdb0010fe23c4d4f9b5a572919c4be94a1aad4fd070220849248cdb18c5b1c4bc478b
diff --git a/app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild b/app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild
new file mode 100644
index 000000000000..a6242fea4889
--- /dev/null
+++ b/app-text/paperwork-backend/paperwork-backend-2.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backend part of Paperwork (Python API, no UI)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/openpaperwork-core[${PYTHON_USEDEP}]
+ app-text/openpaperwork-gtk[${PYTHON_USEDEP}]
+ app-text/poppler[introspection]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ dev-python/whoosh[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ )
+"
+S=${WORKDIR}/paperwork-${PV}/${PN}
+
+distutils_enable_tests unittest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}