summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-09-26 11:53:06 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-09-26 11:53:06 +0200
commit97495c2fd9723a9a6a6d6fad62ceb535200f2736 (patch)
tree6481ce5053607d964a51809a58ea56d1f8d8e776 /app-text
parentapp-text/openpaperwork-core: drop 2.2.2 (diff)
downloadgentoo-97495c2fd9723a9a6a6d6fad62ceb535200f2736.tar.gz
gentoo-97495c2fd9723a9a6a6d6fad62ceb535200f2736.tar.bz2
gentoo-97495c2fd9723a9a6a6d6fad62ceb535200f2736.zip
app-text/openpaperwork-core: add 2.2.5
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/openpaperwork-core/Manifest1
-rw-r--r--app-text/openpaperwork-core/openpaperwork-core-2.2.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-text/openpaperwork-core/Manifest b/app-text/openpaperwork-core/Manifest
index 72f5b5828689..22d63503ab21 100644
--- a/app-text/openpaperwork-core/Manifest
+++ b/app-text/openpaperwork-core/Manifest
@@ -1 +1,2 @@
DIST paperwork-2.2.3.tar.bz2 2531208 BLAKE2B 6259a9b7a916ad71fc0f0747ce0c17e874dbff962c3d8b46c4c25c2a119de6d27f0ce7ce262dfbf7290fa436726fc538d9bead2664d7f158d51634eece768620 SHA512 68bad3ccc9ed2fdea2b1336945ca4f11de5b0a2249d5f043dc34d620ae5bf6627c0255d4776a5c19e9d266972403023f0b63eb3bf694d7a33051b53239c017bf
+DIST paperwork-2.2.5.tar.bz2 2515993 BLAKE2B 3d4e6607d06efc40939fb1d6df72937acb58d54200be96f8c276efe2564ec3e67cafde11e1d8733ff7fd9647b3f30410f9eb584569d56efc3ea5bff21b25acb1 SHA512 60e8acc439bd935f402871208b6acccda033c6324b734aac7adde45716c0e44770902bf97499c10d11af171be5c8bd8ab832b714a972bac27cd274ff5b9fb8ef
diff --git a/app-text/openpaperwork-core/openpaperwork-core-2.2.5.ebuild b/app-text/openpaperwork-core/openpaperwork-core-2.2.5.ebuild
new file mode 100644
index 000000000000..73f4d76b2a24
--- /dev/null
+++ b/app-text/openpaperwork-core/openpaperwork-core-2.2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core part of Paperwork (plugin management)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="https://gitlab.gnome.org/World/OpenPaperwork/paperwork/-/archive/${PV}/paperwork-${PV}.tar.bz2"
+S=${WORKDIR}/paperwork-${PV}/${PN}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/distro[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-apps/which
+ sys-devel/gettext"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}