summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2025-01-06 10:40:47 -0800
committerPatrick McLean <chutzpah@gentoo.org>2025-01-06 10:41:26 -0800
commitb34450639b0f99e0fc8d4562e1ba78edb3819afc (patch)
tree66b7cafca54bffc19799fc3d1fd407d9661a91a0 /app-text
parentdev-util/lcov: Sync 9999 (diff)
downloadgentoo-b34450639b0f99e0fc8d4562e1ba78edb3819afc.tar.gz
gentoo-b34450639b0f99e0fc8d4562e1ba78edb3819afc.tar.bz2
gentoo-b34450639b0f99e0fc8d4562e1ba78edb3819afc.zip
app-text/lowdown: add 1.4.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lowdown/Manifest1
-rw-r--r--app-text/lowdown/lowdown-1.4.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
index 5cfe0176e42b..e64a6f2e23ca 100644
--- a/app-text/lowdown/Manifest
+++ b/app-text/lowdown/Manifest
@@ -2,3 +2,4 @@ DIST lowdown-1.1.1.tar.gz 600635 BLAKE2B 39c0a2472ff6b9b3fa2b6d72c1f2d482592976f
DIST lowdown-1.3.0.tar.gz 666560 BLAKE2B 8bf9da6163a65bff7ac5774d0d31a0dc1438832944b2560a9f725bf9c83c359575fdb828d5065a0138e84466c9a95ca514c72cba6c457a0bb02f9e4558cce017 SHA512 ac51e8ff74450bf02d3c8e41f129f15f2ac92d47a07c020f10eea143b506fd113afac0e9bec447c336cf70176ebc886a8933fa38f5779931c9dfd9c06421fcda
DIST lowdown-1.3.1.tar.gz 668638 BLAKE2B 5d3541e104a25519a580d6b0e8fdfdb03642dcefcdab016f8d1744f5dcd704611d792ca79b988962a014cbcfb20d05e8a8be62eb50708e4c85c5a3d1fe512df1 SHA512 b530bd0ad050a1197e04de971bb10e63c185736f487bcf91467f53d9c63b698aa40d364f8a0d340e3bbf929a9318050c68fdc8127c5ddf526bded327f57419df
DIST lowdown-1.3.2.tar.gz 670610 BLAKE2B 80238e7c6a27c45d6b3f65fbb9435639db5f424aad28c05a94093c5fab3982b1b05b5c3d779e5f74d8b2e71046301c2e3c0ee83496f44f6b8597cd0b3797eb14 SHA512 9592fd270c61d7e827a0e7885ce5faef545a33e61afa0d4cf4549cf5866d82873b042a9cb4465d7b504c686a7b89c748257c470c3b3ccb1ec6f1203a7e6bf392
+DIST lowdown-1.4.0.tar.gz 675327 BLAKE2B 1e734acefe3d293dd6e60f27ff943b484ac99a9e393fd118df09be6dd9671294a91de306393817af9422fec67ed9eda22e2515538b490ac07bdd93ac2e5617e4 SHA512 61b88fc24c9c69a324536bc5cc3edbd453f59945cda264df8751cf361992487081911d3ba6cb04346d5ef451d96a4b56e69a76985849349ef049eca0a098b7ee
diff --git a/app-text/lowdown/lowdown-1.4.0.ebuild b/app-text/lowdown/lowdown-1.4.0.ebuild
new file mode 100644
index 000000000000..87a527ff5117
--- /dev/null
+++ b/app-text/lowdown/lowdown-1.4.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ virtual/libcrypt:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+# configure tests for a bunch of BSD functions on Linux
+QA_CONFIG_IMPL_DECL_SKIP=(
+ crypt_newhash
+ crypt_checkpass
+ warnc
+ errc
+ getexecname
+ getprogname
+ memset_s
+ pledge
+ recallocarray
+ strlcat
+ strlcpy
+ strtonum
+ TAILQ_FOREACH_SAFE
+ unveil
+)
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.10.0-pkgconfig-libmd.patch"
+ "${FILESDIR}/lowdown-1.3.0-shared-linking.patch"
+)
+
+src_configure() {
+ append-flags -fPIC
+ tc-export CC AR
+
+ ./configure \
+ PREFIX="/usr" \
+ MANDIR="/usr/share/man" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LIBDIR="/usr/$(get_libdir)" \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}" emake regress
+}