summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-09 15:54:07 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-09 18:47:27 -0500
commitb5248bbb1b5557aea56b4e1ee3d0d122e03e97d1 (patch)
treeb2ada0f1a7298abf4d7b56c344ccc7d4cb8003c4 /app-text
parentdev-libs/unittest++: Fix libdir (diff)
downloadgentoo-b5248bbb1b5557aea56b4e1ee3d0d122e03e97d1.tar.gz
gentoo-b5248bbb1b5557aea56b4e1ee3d0d122e03e97d1.tar.bz2
gentoo-b5248bbb1b5557aea56b4e1ee3d0d122e03e97d1.zip
app-text/enchant: Version bump to 2.2.15
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.2.15.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 59797f9d89b2..a36567f11191 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,2 +1,3 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
+DIST enchant-2.2.15.tar.gz 990693 BLAKE2B 09d380fc90cf8404345e88fb4e676f92e795b43e1caa5f21e52c6f3037268b1959e9cd1adf04b08e05fce78dbbcfd3163795e8d2079c484c530065566a0307f2 SHA512 e29b3a85d993af28044a86dd23a3ca74c7d50b4218e542c380053a3eaf70c3ea2406feb3361ba8e793bac586c252330bb20fb56c65f3a0a54f63f103cc0abb35
DIST enchant-2.2.8.tar.gz 976715 BLAKE2B 50a96c69b6f6575db0a8d6f30420db4b273901a9a0261ae606d81d96b044ece03078a2549f34972fef47a36f0b85c27af90c90c2f2efab2fb258e17621d927af SHA512 4bfa771af0deab3d0ca5523abab1fdb14cb596747dba7cf887e8cd812601015f52502cbd3df68247f102bba259cb281414e9ccde83b8bdd3c8cc83c2fcbc9090
diff --git a/app-text/enchant/enchant-2.2.15.ebuild b/app-text/enchant/enchant-2.2.15.ebuild
new file mode 100644
index 000000000000..077139d3fce4
--- /dev/null
+++ b/app-text/enchant/enchant-2.2.15.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+IUSE="aspell +hunspell test"
+REQUIRED_USE="|| ( hunspell aspell )"
+
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )"
+BDEPEND="virtual/pkgconfig"
+
+RESTRICT="test" # Tests fail
+
+src_configure() {
+ # TODO: Add app-text/nuspell support
+ econf \
+ --datadir="${EPREFIX}"/usr/share/enchant-2 \
+ --disable-static \
+ $(use_enable test relocatable)
+ $(use_with aspell) \
+ $(use_with hunspell) \
+ --without-nuspell \
+ --without-hspell \
+ --without-voikko \
+ --without-applespell \
+ --without-zemberek \
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}