summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-09-23 11:24:51 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-09 13:29:00 +0100
commitde343959bfd93421b357f37cdc1d80fd83fc6ae2 (patch)
tree6821407c3439533623bfc470bf62600836c93277 /app-text
parentdev-lang/rust: update DEPEND (diff)
downloadgentoo-de343959bfd93421b357f37cdc1d80fd83fc6ae2.tar.gz
gentoo-de343959bfd93421b357f37cdc1d80fd83fc6ae2.tar.bz2
gentoo-de343959bfd93421b357f37cdc1d80fd83fc6ae2.zip
app-text/iso-codes: Bump to 4.17.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38741 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/iso-codes/Manifest1
-rw-r--r--app-text/iso-codes/iso-codes-4.17.0.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-text/iso-codes/Manifest b/app-text/iso-codes/Manifest
index 0f1bd88a2f75..151a99a63386 100644
--- a/app-text/iso-codes/Manifest
+++ b/app-text/iso-codes/Manifest
@@ -1 +1,2 @@
DIST iso-codes-v4.16.0.tar.gz 15163129 BLAKE2B 8fcdb3c12c502c1e14169765db9c9dd7778fc5d4bb0da37aa6b27efeebd5ce9f3e825e5b1a7ae8d659babf2d6b9124af08b40ed8a2a1235e88df50be9c204ca5 SHA512 04d93eb37ff309c850a1af6d4cf6bb92a16e25ee35ee12e16325f6e7b476ba40bbf5d11e2f4c425111220480911b1dbc9e244189ea7487f1f0ea4dbce2307c96
+DIST iso-codes-v4.17.0.tar.gz 15459699 BLAKE2B b788e7b9f48e76667e2a7e97367faf7f5229ce66ba1b2d4e458620af4cc189f026b76c580607f7d95b2adda319137964d6e95e683f9363f3825a71c8c6792db9 SHA512 9731270513aa42bda96f277528cf40a47ccdbf7c864ba8a9015f1007ef79cb16aaed0b1c3dd18fca30c923a45e0906f0cc5366fabb85e144fcfeaf82b1943a41
diff --git a/app-text/iso-codes/iso-codes-4.17.0.ebuild b/app-text/iso-codes/iso-codes-4.17.0.ebuild
new file mode 100644
index 000000000000..dc0c34d10348
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-4.17.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+PLOCALES="ab ace ach af ak am an ar as ast ay az ba bar be bg bi bn bn_BD bn_IN br bs byn ca ce ch chr ckb crh cs csb cv cy da de dv dz ee el en eo es et eu fa ff fi fil fo fr frp fur fy ga gez gl gn gu gv ha haw he hi hr ht hu hy ia id io is it iu ja jam ka kab ki kk kl km kmr kn ko kok kv kw ky lo lt lv mai mhr mi mk ml mn mr ms mt my na nah nb_NO ne nl nn nso nv oc or pa pa_PK pap pi pl ps pt pt_BR ro ro_MD ru rw sc sd si sk sl so son sq sr sr@latin sv sw ta te tg th ti tig tk tl tr tt tt@iqtelif tzm ug uk ur uz ve vi wa wal wo xh yo zh_CN zh_HK zh_Hans zh_Hant zh_TW zu"
+
+inherit python-any-r1
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="https://salsa.debian.org/iso-codes-team/iso-codes"
+SRC_URI="https://salsa.debian.org/${PN}-team/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+# This ebuild does not install any binaries.
+RESTRICT="binchecks strip"
+
+DOCS=( CHANGELOG.md README.md )
+
+# plocale_find_changes doesn't support multiple directories,
+# so need to do the update scan ourselves.
+check_existing_locales() {
+ local std loc all_locales=()
+
+ ebegin "Looking for new locales"
+ for std in "${all_stds[@]}"; do
+ pushd "${std}" >/dev/null || die
+ for loc in *.po; do
+ all_locales+=( "${loc%.po}" )
+ done
+ popd >/dev/null
+ done
+
+ all_locales=$(echo $(printf '%s\n' "${all_locales[@]}" | LC_COLLATE=C sort -u))
+ if [[ ${PLOCALES} != "${all_locales}" ]]; then
+ eend 1
+ eerror "There are changes in locales! This ebuild should be updated to:"
+ eerror "PLOCALES=\"${all_locales}\""
+ die "Update PLOCALES in the ebuild"
+ else
+ eend 0
+ fi
+}
+
+src_prepare() {
+ default
+
+ local std loc mylinguas
+ local all_stds=( iso_15924 iso_3166-{1,2,3} iso_4217 iso_639-{2,3,5} )
+
+ check_existing_locales
+
+ # Modify the Makefiles so they only install requested locales.
+ for std in "${all_stds[@]}"; do
+ einfo "Preparing ${std} ..."
+ pushd "${std}" >/dev/null || die
+ mylinguas=()
+ for loc in *.po; do
+ if has ${loc%.po} ${LINGUAS-${loc%.po}}; then
+ mylinguas+=( "${loc}" )
+ fi
+ done
+
+ sed \
+ -e "/^pofiles =/s:=.*:= ${mylinguas[*]}:" \
+ -e "/^mofiles =/s:=.*:= ${mylinguas[*]/%.po/.mo}:" \
+ -i Makefile.am Makefile.in || die "sed in ${std} folder failed"
+ popd >/dev/null
+ done
+}