summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 17:29:27 -0500
committerSam James <sam@gentoo.org>2024-02-29 23:57:39 +0000
commitefd1a1f09c5c37ee32ea6e1185a0d10305097ff6 (patch)
tree5bfda0688b96a3d5adcf5f7f3c4aa32a59f8370e /app-text
parentapp-text/groonga: require acct-* at build time, not merge time (diff)
downloadgentoo-efd1a1f09c5c37ee32ea6e1185a0d10305097ff6.tar.gz
gentoo-efd1a1f09c5c37ee32ea6e1185a0d10305097ff6.tar.bz2
gentoo-efd1a1f09c5c37ee32ea6e1185a0d10305097ff6.zip
app-text/pspdftool: mark LTO-unsafe, mark strict-aliasing unsafe
The software is: - dead upstream since 2015 - maintainer-needed in gentoo - no reverse dependencies - unstable-only - a walking strict-aliasing problem It's not getting fixed any time soon, and there's nowhere to report its issues, so just filter out the most dangerous flags and pray nothing explodes. Closes: https://bugs.gentoo.org/855023 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pspdftool/pspdftool-0.03.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-text/pspdftool/pspdftool-0.03.ebuild b/app-text/pspdftool/pspdftool-0.03.ebuild
index 5dff5b9d0d33..97d533be413d 100644
--- a/app-text/pspdftool/pspdftool-0.03.ebuild
+++ b/app-text/pspdftool/pspdftool-0.03.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
HOMEPAGE="https://sourceforge.net/projects/pspdftool"
@@ -24,6 +24,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing; do not trust for LTO-safety either.
+ # https://bugs.gentoo.org/855023
+ # Upstream is dead for nearly a decade. Not forwarded.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
econf $(use_with zlib)
}