summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-07 17:17:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-07 20:06:27 +0100
commit0b12825a5b2d200a606fd40c4a8a7a2c74a599f5 (patch)
treef0740e23f9d37cf21f8f616a1fa30e4538f2acba /dev-build
parentkde-misc/zanshin: 24.08.3 version bump (diff)
downloadgentoo-0b12825a5b2d200a606fd40c4a8a7a2c74a599f5.tar.gz
gentoo-0b12825a5b2d200a606fd40c4a8a7a2c74a599f5.tar.bz2
gentoo-0b12825a5b2d200a606fd40c4a8a7a2c74a599f5.zip
dev-build/dolphin-plugins-makefileactions: 24.08.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-build')
-rw-r--r--dev-build/dolphin-plugins-makefileactions/Manifest1
-rw-r--r--dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-build/dolphin-plugins-makefileactions/Manifest b/dev-build/dolphin-plugins-makefileactions/Manifest
index d23d32d9b257..d26c9a3ea89b 100644
--- a/dev-build/dolphin-plugins-makefileactions/Manifest
+++ b/dev-build/dolphin-plugins-makefileactions/Manifest
@@ -1 +1,2 @@
DIST dolphin-plugins-24.08.2.tar.xz 317744 BLAKE2B 5ea4755bee6d5ec3a3dbb30e1afe290818bdb57e14421fbb9a907f8f791e6001eef8cf134ec3d9415ca43824153bf55096f8f3e1ee2434a58795da979957a2db SHA512 c89a7a6d9f1a2d567522e126e25b52290205f96166ceb9b95c8aa0fbcf28424891ed1e60a1cdd4b158fd4ed48bb3b7a6bcdb6c79fe712b1cbdeb13c0c275a1f5
+DIST dolphin-plugins-24.08.3.tar.xz 317540 BLAKE2B 54fa2e13be2cceb53b12b1edb2d6d7c1793f6ba2bbec67e9e00121b33683aa6bd4895392cbdf5aa7627958c6323984ae3db8b5bbf6b14faba86b13181e0a2614 SHA512 05da7ac7b3ebe085cf0808d8e1eba49372bfeb1488800f40c1d0b9025e743efede1200095a1e660c1d538b2cc1b19f0f717f3d0723043517859f5c2015f961ce
diff --git a/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild
new file mode 100644
index 000000000000..f3c4f87c8cdd
--- /dev/null
+++ b/dev-build/dolphin-plugins-makefileactions/dolphin-plugins-makefileactions-24.08.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="makefileactions"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Makefile targets integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/dolphin-plugins-subversion-24.08.2-r1
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # kcompletion, ktextwidgets only required by other plugins
+ ecm_punt_kf_module Completion
+ ecm_punt_kf_module TextWidgets
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}