summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorsin-ack <sin-ack@protonmail.com>2024-11-10 21:14:30 +0100
committerSam James <sam@gentoo.org>2024-11-11 22:24:19 +0000
commitc2deaaa456af4bd5409e60b5cd1183b7406f71b8 (patch)
treec79ece7a20ea9d54412a7c6ced0214a31ecba459 /dev-cpp/edencommon
parentdev-cpp/fb303: new package, add 2024.11.04.00 (diff)
downloadgentoo-c2deaaa456af4bd5409e60b5cd1183b7406f71b8.tar.gz
gentoo-c2deaaa456af4bd5409e60b5cd1183b7406f71b8.tar.bz2
gentoo-c2deaaa456af4bd5409e60b5cd1183b7406f71b8.zip
dev-cpp/edencommon: add 2024.11.04.00
Signed-off-by: sin-ack <sin-ack@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/edencommon')
-rw-r--r--dev-cpp/edencommon/Manifest1
-rw-r--r--dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/edencommon/Manifest b/dev-cpp/edencommon/Manifest
index 8dad4592cb9c..8565d9281f21 100644
--- a/dev-cpp/edencommon/Manifest
+++ b/dev-cpp/edencommon/Manifest
@@ -1 +1,2 @@
DIST edencommon-2023.06.19.00.gh.tar.gz 146697 BLAKE2B 8b2419671c50eea43aa4b8d5d85eee75ed24ff9745a71c2d11b1994605552ffc288b55520639585631aed0e2528482a01daa9b47ef676fed7c14b4c7d75d018f SHA512 47b37a6acf93a6c6f2903f3113021aa1d54230cf3e31a8071aa7f276601a8eae56bd95767ec23c3027695367261d4db1483b637513c72ce220778f1f1a4c42ce
+DIST edencommon-2024.11.04.00.gh.tar.gz 311977 BLAKE2B 2b152c3cc243c684b8b802981494816b5114e100bc31cc07a96d000dae2be70da4e205d52a30776e930c7c01d63e01baa102cb49a431c961ef133ed936c5eb76 SHA512 c1c428d7392d279e1b0c4348b0fd41ef9a53e50d8a65ff513a56919a7834c118af4adb1145153d10821efb7c8b30b62c1c6d6365b368b90cd567e350c8be0e81
diff --git a/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild b/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild
new file mode 100644
index 000000000000..c53780c9b1f9
--- /dev/null
+++ b/dev-cpp/edencommon/edencommon-2024.11.04.00.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/fb303
+# dev-cpp/fbthrift
+# dev-cpp/fizz
+# dev-cpp/folly
+# dev-cpp/mvfst
+# dev-cpp/wangle
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="Shared library for Watchman and Eden projects"
+HOMEPAGE="https://github.com/facebookexperimental/edencommon"
+SRC_URI="https://github.com/facebookexperimental/edencommon/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="llvm-libunwind"
+
+RDEPEND="
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ ~dev-cpp/folly-${PV}:=
+ ~dev-cpp/fb303-${PV}:=
+ ~dev-cpp/wangle-${PV}:=
+ ~dev-cpp/fbthrift-${PV}:=
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/gtest
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake_src_configure
+}