summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Henke <Jan.Henke@taujhe.de>2020-06-14 14:32:40 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-06-14 13:28:30 -0700
commite5da0f47e9281acdc6bbd58adb677e78ccd97496 (patch)
treedc027a7d6411d0da0ec8985070502d66b12f7ed6 /dev-cpp/ms-gsl/ms-gsl-3.1.0.ebuild
parentnet-dns/bind-tools: stable 9.14.12 for ppc (diff)
downloadgentoo-e5da0f47e9281acdc6bbd58adb677e78ccd97496.tar.gz
gentoo-e5da0f47e9281acdc6bbd58adb677e78ccd97496.tar.bz2
gentoo-e5da0f47e9281acdc6bbd58adb677e78ccd97496.zip
dev-cpp/ms-gsl: Version bump 3.1.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jan Henke <Jan.Henke@taujhe.de> Closes: https://github.com/gentoo/gentoo/pull/16237 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-cpp/ms-gsl/ms-gsl-3.1.0.ebuild')
-rw-r--r--dev-cpp/ms-gsl/ms-gsl-3.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/ms-gsl/ms-gsl-3.1.0.ebuild b/dev-cpp/ms-gsl/ms-gsl-3.1.0.ebuild
new file mode 100644
index 000000000000..a83f3f082bb8
--- /dev/null
+++ b/dev-cpp/ms-gsl/ms-gsl-3.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Guideline Support Library implementation by Microsoft"
+HOMEPAGE="https://github.com/Microsoft/GSL"
+SRC_URI="https://github.com/Microsoft/GSL/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/GSL-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# header only library
+RDEPEND=""
+DEPEND="test? ( >=dev-cpp/gtest-1.9.0_pre20190607 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-disable_Werror-644042.patch"
+ "${FILESDIR}/${PN}-3.0.0-use_system_gtest.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DGSL_TEST=$(usex test)
+ )
+ cmake-utils_src_configure
+}