summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/pgxnclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/pgxnclient')
-rw-r--r--dev-db/pgxnclient/Manifest2
-rw-r--r--dev-db/pgxnclient/metadata.xml12
-rw-r--r--dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild30
-rw-r--r--dev-db/pgxnclient/pgxnclient-1.2.1.ebuild30
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-db/pgxnclient/Manifest b/dev-db/pgxnclient/Manifest
new file mode 100644
index 000000000000..9425b0cea5b2
--- /dev/null
+++ b/dev-db/pgxnclient/Manifest
@@ -0,0 +1,2 @@
+DIST pgxnclient-1.2.1.tar.gz 87275 SHA256 8e3022bc960aa5d5fc7d4c564786087693a1a99f15e025ad920fc0aa378e1d67 SHA512 3fa864b1ebb5dedaf75515b5efe4c453f02acff558f7b82d2648da62e58c93e050049a7688171a69593784d9963bb62f4ad3674d526284554dbeb4f4a4ea1dbf WHIRLPOOL f0e5df1e841a8da59a0fed16643e30120c188813c69307e2db6055c25d4298368a56c89f08dd54edbb6c6dbc1a8676a462fc9fe1b7982c8334d2c6af040d0d99
+DIST pgxnclient-1.2.tar.gz 86436 SHA256 ad3768d1ed83ea3af8a3ad9abf11fd164dbdeb355371819bce072dc581f43c42 SHA512 d677f8d5346caf4de5d7e0d4e4031b8bdd932e343af7fc33e8895ebe51b1e9e6a11d7300d9e98ddc10242854f7d39c0a4196f41938e42f0b0e5158454e386deb WHIRLPOOL fcb76ce45b4898a56f2ee99317874b1cbecafc67d37d1edabc55c9f6bea644d757ac1ab396fc5f3d0a8d98040e2f70211d3a712a8219c1ba2da23c4fa22b41fa
diff --git a/dev-db/pgxnclient/metadata.xml b/dev-db/pgxnclient/metadata.xml
new file mode 100644
index 000000000000..0c269f078c8d
--- /dev/null
+++ b/dev-db/pgxnclient/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>postgresql</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pgxnclient</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild b/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
new file mode 100644
index 000000000000..86572ccdd8a7
--- /dev/null
+++ b/dev-db/pgxnclient/pgxnclient-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL Extension Network Client"
+HOMEPAGE="http://pgxnclient.projects.postgresql.org/ http://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-db/postgresql-9.1[server]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # suite written onlt for py2
+ pushd ${PN} > /dev/null
+ if ! python_is_python3; then
+ PYTHONPATH=../ "${PYTHON}" -m unittest discover || die "tests failed"
+ fi
+ popd > dev/null
+}
diff --git a/dev-db/pgxnclient/pgxnclient-1.2.1.ebuild b/dev-db/pgxnclient/pgxnclient-1.2.1.ebuild
new file mode 100644
index 000000000000..32238af0f3cb
--- /dev/null
+++ b/dev-db/pgxnclient/pgxnclient-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL Extension Network Client"
+HOMEPAGE="http://pgxnclient.projects.postgresql.org/ http://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-db/postgresql-9.1[server]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ # suite written onlt for py2
+ pushd ${PN} > /dev/null
+ if ! python_is_python3; then
+ PYTHONPATH=../ "${PYTHON}" -m unittest discover || die "tests failed"
+ fi
+ popd > dev/null
+}