summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-02-18 11:39:41 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-02-18 11:40:25 +0300
commit754dfca1c102e23a484f204744ca46b19316a473 (patch)
tree2eaeeff46d72936b0ee47f283df0f51838a53c69 /dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
parentdev-db/sqlite: stable 3.21.0 for ia64, bug #641108 (diff)
downloadgentoo-754dfca1c102e23a484f204744ca46b19316a473.tar.gz
gentoo-754dfca1c102e23a484f204744ca46b19316a473.tar.bz2
gentoo-754dfca1c102e23a484f204744ca46b19316a473.zip
dev-db/sqlcipher: version bump
Fix automagic dependency on dev-libs/libedit Reported-by: Andreas Sturmlechner <asturm@gentoo.org> Gentoo-Bug: 634826 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-db/sqlcipher/sqlcipher-3.4.2.ebuild')
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.4.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild b/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
new file mode 100644
index 000000000000..fce76e2a5797
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-3.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="https://www.zetetic.net/sqlcipher/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libedit readline libressl static-libs tcl test"
+
+# Tcl is always needed by buildsystem
+RDEPEND="
+ libedit? ( dev-libs/libedit[${MULTILIB_USEDEP}] )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-lang/tcl:*"
+
+# Libedit and readline support are mutually exclusive
+# Testsuite requires compilation with TCL, bug #582584
+REQUIRED_USE="
+ libedit? ( !readline )
+ test? ( tcl )
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ append-cflags -DSQLITE_HAS_CODEC
+ eapply_user
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-fts3 \
+ --enable-fts4 \
+ --enable-fts5 \
+ --enable-json1 \
+ --enable-tempstore \
+ $(use_enable libedit editline) \
+ $(use_enable readline) \
+ $(use_enable static-libs static) \
+ $(use_enable tcl)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}