summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:02:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:02:52 +0100
commit2838c5ea43d7d28d86813d1ad535e3bea7b61953 (patch)
treec768581e9c4c5d0679051709dccf906c7612242b /dev-debug
parentsys-libs/compiler-rt: Remove old (diff)
downloadgentoo-2838c5ea43d7d28d86813d1ad535e3bea7b61953.tar.gz
gentoo-2838c5ea43d7d28d86813d1ad535e3bea7b61953.tar.bz2
gentoo-2838c5ea43d7d28d86813d1ad535e3bea7b61953.zip
dev-debug/lldb: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/lldb/Manifest1
-rw-r--r--dev-debug/lldb/lldb-20.0.0_pre20241130.ebuild110
2 files changed, 0 insertions, 111 deletions
diff --git a/dev-debug/lldb/Manifest b/dev-debug/lldb/Manifest
index 06da38b8d6ec..211b9e5983a7 100644
--- a/dev-debug/lldb/Manifest
+++ b/dev-debug/lldb/Manifest
@@ -12,4 +12,3 @@ DIST llvm-project-19.1.4.src.tar.xz.sig 438 BLAKE2B b0925bdb761046d69779e0b035e2
DIST llvm-project-19.1.5.src.tar.xz 141243716 BLAKE2B 228fc66ab688abfc16f31b2cd83163b81ef61604ace21eab69a1776f0dc88cbe8fa831162205849e5be3975a214136399572b4ad1b908986e37b2d38a1a7fa5d SHA512 648854e9c91fdcc5c677ce3800e046f2060b998a45cf9f7eebe02898431b3924f9348b6fc366102cd4fdda72dcb8f32076f98aa69927e0e20b3f1007fba10b22
DIST llvm-project-19.1.5.src.tar.xz.sig 438 BLAKE2B 1d40a5c5405f99ef86e3360f9ea153afd1ae4001697210fd799a988113e8a3cef39e2c4794edd9332f384d8490f4ce2ab6bee6d98f794f84775807f833b81c0a SHA512 a438c86ce882eb1ac3e50842937068794ed162bb1b7ded68a2fe3ec2ab4f57cc38aee667cfb46afe6da22eef7ed1cb65820a473f63bd5a0dc6aad41df7bfad54
DIST llvm-project-32f7f0010bca99ee4bd917f57272733fb2bf3bd9.tar.gz 223983502 BLAKE2B fd3e6b0b795abc42568ef98fa774d927029c18838a5d0f34eaa66c37976444a63f2fc5d883f3bf3a98533f51e387936f1c659230f31c757d26153425696a16cd SHA512 65a345ad5b77c627008f759947e5e9f28a62c8992d7146113e0446e5849feaf9088c15c8b22ca0824af5b927d6a417f5326258b489fb8ccea78ec9e0e0fe8fba
-DIST llvm-project-a348f223cab54b21a7b1c38dec7bc6aa2f81c949.tar.gz 223630067 BLAKE2B 3c2121a8d13e3a84a9ee98d17c58e5fd5a31d5870ac21c633c78c49b4af0c401310f7e91f64ff3b7cf7f6e8d205c730458b8b1101b1255f422659974d48e2ecb SHA512 33cc09a904e4fe0d529611a1d71d764e6d49f014cea903aadc0755d0420f65cfc763fdcfd4bb9a96adad79ce1c4475d8c005dcac37c4fe130a1fb3665172f1db
diff --git a/dev-debug/lldb/lldb-20.0.0_pre20241130.ebuild b/dev-debug/lldb/lldb-20.0.0_pre20241130.ebuild
deleted file mode 100644
index 68e15ff5df60..000000000000
--- a/dev-debug/lldb/lldb-20.0.0_pre20241130.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..13} )
-inherit cmake flag-o-matic llvm.org llvm-utils python-single-r1
-
-DESCRIPTION="The LLVM debugger"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0/${LLVM_SOABI}"
-IUSE="+debug debuginfod +libedit lzma ncurses +python test +xml"
-RESTRICT="test"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DEPEND="
- debuginfod? (
- net-misc/curl:=
- dev-cpp/cpp-httplib:=
- )
- libedit? ( dev-libs/libedit:0= )
- lzma? ( app-arch/xz-utils:= )
- ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
- xml? ( dev-libs/libxml2:= )
- ~sys-devel/clang-${PV}
- ~sys-devel/llvm-${PV}[debuginfod=]
-"
-RDEPEND="
- ${DEPEND}
- python? (
- ${PYTHON_DEPS}
- )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- python? (
- >=dev-lang/swig-3.0.11
- )
- test? (
- $(python_gen_cond_dep "
- ~dev-python/lit-${PV}[\${PYTHON_USEDEP}]
- dev-python/psutil[\${PYTHON_USEDEP}]
- ")
- sys-devel/lld
- )
-"
-
-LLVM_COMPONENTS=( lldb cmake llvm/utils )
-LLVM_TEST_COMPONENTS=( llvm/lib/Testing/Support third-party )
-llvm.org_set_globals
-
-src_configure() {
- llvm_prepend_path "${LLVM_MAJOR}"
-
- # bug #858389 (https://github.com/llvm/llvm-project/issues/83636)
- filter-lto
-
- # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
- use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
-
- local mycmakeargs=(
- -DLLDB_ENABLE_CURSES=$(usex ncurses)
- -DLLDB_ENABLE_LIBEDIT=$(usex libedit)
- -DLLDB_ENABLE_PYTHON=$(usex python)
- -DLLDB_ENABLE_LUA=OFF
- -DLLDB_ENABLE_LZMA=$(usex lzma)
- -DLLDB_ENABLE_LIBXML2=$(usex xml)
- -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-
- -DLLDB_INCLUDE_TESTS=$(usex test)
-
- -DCLANG_LINK_CLANG_DYLIB=ON
- # TODO: fix upstream to detect this properly
- -DHAVE_LIBDL=ON
- -DHAVE_LIBPTHREAD=ON
-
- # normally we'd have to set LLVM_ENABLE_TERMINFO, HAVE_TERMINFO
- # and TERMINFO_LIBS... so just force FindCurses.cmake to use
- # ncurses with complete library set (including autodetection
- # of -ltinfo)
- -DCURSES_NEED_NCURSES=ON
-
- -DCLANG_RESOURCE_DIR="../../../clang/${LLVM_MAJOR}"
-
- -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
- -DPython3_EXECUTABLE="${PYTHON}"
- )
- use test && mycmakeargs+=(
- -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="$(get_lit_flags)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local -x LIT_PRESERVES_TMP=1
- cmake_build check-lldb-{shell,unit}
- # failures + hangs
- #use python && cmake_build check-lldb-api
-}
-
-src_install() {
- cmake_src_install
- find "${D}" -name '*.a' -delete || die
-
- use python && python_optimize
-}