summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2024-04-14 11:05:30 +0200
committerSven Wegener <swegener@gentoo.org>2024-11-22 00:07:57 +0100
commitac4b5698234958d927d9f03372a1f7720be02030 (patch)
treed86b3cd082fa860f1c9988a717c52d098b742dc3 /dev-debug
parentdev-perl/Test-Cmd: Keyword 1.90.0 riscv, #943635 (diff)
downloadgentoo-ac4b5698234958d927d9f03372a1f7720be02030.tar.gz
gentoo-ac4b5698234958d927d9f03372a1f7720be02030.tar.bz2
gentoo-ac4b5698234958d927d9f03372a1f7720be02030.zip
dev-debug/systemtap: move setuptools dep to BDEPEND
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/systemtap/systemtap-4.8.ebuild6
-rw-r--r--dev-debug/systemtap/systemtap-5.0-r1.ebuild6
-rw-r--r--dev-debug/systemtap/systemtap-5.1-r1.ebuild2
-rw-r--r--dev-debug/systemtap/systemtap-5.1.ebuild2
-rw-r--r--dev-debug/systemtap/systemtap-9999.ebuild2
5 files changed, 11 insertions, 7 deletions
diff --git a/dev-debug/systemtap/systemtap-4.8.ebuild b/dev-debug/systemtap/systemtap-4.8.ebuild
index 424f64136cb4..f1da9abd10fb 100644
--- a/dev-debug/systemtap/systemtap-4.8.ebuild
+++ b/dev-debug/systemtap/systemtap-4.8.ebuild
@@ -38,7 +38,6 @@ DEPEND="
${CDEPEND}
app-alternatives/cpio
app-text/xmlto
- $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
>=sys-devel/gettext-0.18.2
libvirt? ( dev-libs/libxml2 )
@@ -49,7 +48,10 @@ RDEPEND="
acct-group/stapsys
acct-group/stapusr
"
-BDEPEND="test? ( dev-util/dejagnu )"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ test? ( dev-util/dejagnu )
+"
CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
diff --git a/dev-debug/systemtap/systemtap-5.0-r1.ebuild b/dev-debug/systemtap/systemtap-5.0-r1.ebuild
index a82fc3af3eb6..c7d6dcfb96ee 100644
--- a/dev-debug/systemtap/systemtap-5.0-r1.ebuild
+++ b/dev-debug/systemtap/systemtap-5.0-r1.ebuild
@@ -38,7 +38,6 @@ DEPEND="
${CDEPEND}
app-alternatives/cpio
app-text/xmlto
- $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
>=sys-devel/gettext-0.18.2
libvirt? ( dev-libs/libxml2 )
@@ -49,7 +48,10 @@ RDEPEND="
acct-group/stapsys
acct-group/stapusr
"
-BDEPEND="test? ( dev-util/dejagnu )"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
+ test? ( dev-util/dejagnu )
+"
CONFIG_CHECK="~KPROBES ~RELAY ~DEBUG_FS"
ERROR_KPROBES="${PN} requires support for KProbes Instrumentation (KPROBES) - this can be enabled in 'Instrumentation Support -> Kprobes'."
diff --git a/dev-debug/systemtap/systemtap-5.1-r1.ebuild b/dev-debug/systemtap/systemtap-5.1-r1.ebuild
index de32caa4bc1f..959daf66209e 100644
--- a/dev-debug/systemtap/systemtap-5.1-r1.ebuild
+++ b/dev-debug/systemtap/systemtap-5.1-r1.ebuild
@@ -43,7 +43,6 @@ DEPEND="
${CDEPEND}
app-alternatives/cpio
app-text/xmlto
- $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
>=sys-devel/gettext-0.18.2
libvirt? ( dev-libs/libxml2 )
@@ -56,6 +55,7 @@ RDEPEND="
"
# which: https://sourceware.org/PR32106
BDEPEND="
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
test? (
dev-util/dejagnu
|| (
diff --git a/dev-debug/systemtap/systemtap-5.1.ebuild b/dev-debug/systemtap/systemtap-5.1.ebuild
index e8c3b20243c9..5830c0e68aca 100644
--- a/dev-debug/systemtap/systemtap-5.1.ebuild
+++ b/dev-debug/systemtap/systemtap-5.1.ebuild
@@ -43,7 +43,6 @@ DEPEND="
${CDEPEND}
app-alternatives/cpio
app-text/xmlto
- $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
>=sys-devel/gettext-0.18.2
libvirt? ( dev-libs/libxml2 )
@@ -56,6 +55,7 @@ RDEPEND="
"
# which: https://sourceware.org/PR32106
BDEPEND="
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
test? (
dev-util/dejagnu
|| (
diff --git a/dev-debug/systemtap/systemtap-9999.ebuild b/dev-debug/systemtap/systemtap-9999.ebuild
index 4777e9d326b8..b8cba03f7466 100644
--- a/dev-debug/systemtap/systemtap-9999.ebuild
+++ b/dev-debug/systemtap/systemtap-9999.ebuild
@@ -43,7 +43,6 @@ DEPEND="
${CDEPEND}
app-alternatives/cpio
app-text/xmlto
- $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
>=sys-devel/gettext-0.18.2
libvirt? ( dev-libs/libxml2 )
@@ -56,6 +55,7 @@ RDEPEND="
"
# which: https://sourceware.org/PR32106
BDEPEND="
+ $(python_gen_cond_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
test? (
dev-util/dejagnu
|| (