summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2021-12-16 16:08:32 +0100
committerZac Medico <zmedico@gentoo.org>2022-02-12 11:56:50 -0800
commitd3e381e2f54ef8e082a2a88c331b45280525eabb (patch)
tree2c4032b900e14d80c22bffedcdfa463fce6cd41a /dev-dotnet
parentdev-dotnet/dotnet-sdk-bin: bump to 6.0.102 (diff)
downloadgentoo-d3e381e2f54ef8e082a2a88c331b45280525eabb.tar.gz
gentoo-d3e381e2f54ef8e082a2a88c331b45280525eabb.tar.bz2
gentoo-d3e381e2f54ef8e082a2a88c331b45280525eabb.zip
dev-dotnet/dotnet-sdk-bin: add .NET Core 3.1 as a new slot
Signed-off-by: Gergely Nagy <ngg@ngg.hu> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.416.ebuild48
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild5
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.405.ebuild5
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild1
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild1
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild1
7 files changed, 62 insertions, 2 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index 7618c6697449..ad529140839d 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -1,3 +1,6 @@
+DIST dotnet-sdk-3.1.416-linux-arm.tar.gz 126456099 BLAKE2B 2181b3eaa3eb35bfb98015d2c668363acc0071883ecf8367d62b7d4d7d2b94b10401c7e7a93fbb02e323ee6dd27311b6574854bbc4061e2e8d5acbc102a7cb40 SHA512 33a6d64f466839cc30adef87909a2ff98ecdf6bb763b82a7951314ee8eded7dc210297f914d4aa0b9c0b101aa0c33da97cb15ff64c5f83f08b212b885d662e90
+DIST dotnet-sdk-3.1.416-linux-arm64.tar.gz 121467597 BLAKE2B e8148fe25069551dd9df996ca6ca6b754190c805a43e24b4f0b65227eaf70064091d222b6471f16b3eac240425c963c2f23d0673635a6c3fd4f486df73c14672 SHA512 0065c7afb129b1a0e0c11703309f3b45cf9a3c0ea156247f7cc61555f21c37054f215eb77add509dad77b1d388a4e6c585f8a8016109f31c5b64184b25e2c407
+DIST dotnet-sdk-3.1.416-linux-x64.tar.gz 121484416 BLAKE2B 3ffdba4b7a5f7c87ef288d64c891f257b09de9a7ad8d6032d831ac6c57da279b177ba446b1d2eca392c231e10d1ea596914409c5cf8f2584a34a4e0fc555ce42 SHA512 dec1dcf326487031c45dec0849a046a0d034d6cbb43ab591da6d94c2faf72da8e31deeaf4d2165049181546d5296bb874a039ccc2f618cf95e68a26399da5e7f
DIST dotnet-sdk-5.0.301-linux-arm.tar.gz 138735656 BLAKE2B c23732749f67bd2ca63cadba9bcb3f5abd4e10d00fed441825e6a59f9d3a3e663101502e5557dd94e737443cc9bbab0d5dbe8f7ebdbde54586596ec5c520a64f SHA512 89663ffb22299ad626d3f1d5129e493fb8784e6ed854b128a364407a060eec2979cd7d3c9e4f3df8e47ccb72b98ff8b18e8d53c7fb65b3455faa7344f67417a2
DIST dotnet-sdk-5.0.301-linux-arm64.tar.gz 136933875 BLAKE2B 6c48c8a2d47ba5bed47e6176d10e273ec996686cb5a4d5b3239098ff23d44526091f7eae1ce762a2eb2f6f31420cafda84471b936082469eadc8c62aa0dcd8bf SHA512 56e233b8f35abe80984bc8a60028f4f8dbc8543313a0711045ef13c693e11e706ee4809574518f57910ec2c93bed896da32760c8143a298556dc25478caca90f
DIST dotnet-sdk-5.0.301-linux-x64.tar.gz 142255332 BLAKE2B 172888e2eb78d2f768cff6a7e99d6473b469b7cbde74a4eab63e601d85bad118be374f330a413a9b6b3e6773340bdaef8ead4ed54a194189a50cac6b61fac556 SHA512 81cd7a3550a262d5c907030677429fa9a1cb515071274931ab760bd8bb2a14f40c9384c8757e1c1aa681b1de22035f16bf20b41ed208becd054cc9bb1f620322
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.416.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.416.ebuild
new file mode 100644
index 000000000000..a6cb8b1e7120
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-3.1.416.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="3.1"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
index ef420c241e6d..5adae138eb9c 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.301.ebuild
@@ -25,7 +25,10 @@ RDEPEND="
app-crypt/mit-krb5:0/0
dev-util/lttng-ust:0
sys-libs/zlib:0/1
- dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
+ )
"
S=${WORKDIR}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.405.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.405.ebuild
index ef420c241e6d..5adae138eb9c 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.405.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-5.0.405.ebuild
@@ -25,7 +25,10 @@ RDEPEND="
app-crypt/mit-krb5:0/0
dev-util/lttng-ust:0
sys-libs/zlib:0/1
- dotnet-symlink? ( !dev-dotnet/dotnet-sdk[dotnet-symlink(+)] )
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
+ )
"
S=${WORKDIR}
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
index a52d40cfec34..237308fc0fc2 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
@@ -27,6 +27,7 @@ RDEPEND="
sys-libs/zlib:0/1
dotnet-symlink? (
!dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
!dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
)
"
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild
index a52d40cfec34..237308fc0fc2 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild
@@ -27,6 +27,7 @@ RDEPEND="
sys-libs/zlib:0/1
dotnet-symlink? (
!dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
!dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
)
"
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild
index a52d40cfec34..237308fc0fc2 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild
@@ -27,6 +27,7 @@ RDEPEND="
sys-libs/zlib:0/1
dotnet-symlink? (
!dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
!dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
)
"