summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/dc-tool-ip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/dc-tool-ip')
-rw-r--r--dev-embedded/dc-tool-ip/Manifest1
-rw-r--r--dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild43
-rw-r--r--dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch22
-rw-r--r--dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch22
-rw-r--r--dev-embedded/dc-tool-ip/metadata.xml11
5 files changed, 99 insertions, 0 deletions
diff --git a/dev-embedded/dc-tool-ip/Manifest b/dev-embedded/dc-tool-ip/Manifest
new file mode 100644
index 000000000000..42b2c4dd5f54
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/Manifest
@@ -0,0 +1 @@
+DIST dcload-ip-1.0.4-src.tar.gz 104758 SHA256 dc81c28abf11899f22cb53d9de21bb99209e703acca7ae52ea48438b36012946 SHA512 c58f574bf13dd44a00395060af4c718593471242366d09dddb234490d20a6e0322a2c3853613aa1c8a5269802cf6434407d3f6c62c934e8b66f8fc1e86a12536 WHIRLPOOL 4287a318a60495c33dc6ffa0e396b52cc2a6d95f194dbbe800f44a3cff992064a11ac295777edfbe45d35bf095ace6693ba0e67ccc6aec12966a3192ff04ee09
diff --git a/dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild b/dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild
new file mode 100644
index 000000000000..9c1c2103e299
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/dc-tool-ip-1.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="ethernet program loader for the Dreamcast"
+HOMEPAGE="http://cadcdev.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cadcdev/dcload-ip-${PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+S=${WORKDIR}/dcload-ip-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-bfd-update.patch
+ epatch "${FILESDIR}"/${P}-headers.patch
+ append-cppflags -DPACKAGE -DPACKAGE_VERSION #465952
+ sed -i \
+ -e "/^HOSTCC/s:gcc:$(tc-getCC):" \
+ -e "/^HOSTCFLAGS/s:-O2:${CFLAGS} ${CPPFLAGS}:" \
+ -e 's:-L/usr/local/dcdev/lib:$(LDFLAGS):' \
+ -e 's:/usr/local/dcdev/include:.:' \
+ Makefile.cfg || die "sed"
+}
+
+src_compile() {
+ emake -C host-src/tool
+}
+
+src_install() {
+ dobin host-src/tool/dc-tool
+ dodoc README NETWORK CHANGES
+ dodoc -r make-cd
+ if use doc ; then
+ dodoc -r example-src
+ fi
+}
diff --git a/dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch b/dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch
new file mode 100644
index 000000000000..62da02f12e98
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/files/1.0.4-bfd-update.patch
@@ -0,0 +1,22 @@
+--- host-src/tool/dc-tool.c.orig 2004-11-13 19:38:50.007151024 -0500
++++ host-src/tool/dc-tool.c 2004-11-13 19:38:58.320887144 -0500
+@@ -431,13 +431,13 @@
+ if ((section->flags & SEC_HAS_CONTENTS) && (section->flags & SEC_LOAD)) {
+ printf("Section %s, ",section->name);
+ printf("lma 0x%x, ",section->lma);
+- printf("size %d\n",section->_raw_size);
+- if (section->_raw_size) {
+- size += section->_raw_size;
+- inbuf = malloc(section->_raw_size);
+- bfd_get_section_contents(somebfd, section, inbuf, 0, section->_raw_size);
++ printf("size %d\n",section->rawsize);
++ if (section->rawsize) {
++ size += section->rawsize;
++ inbuf = malloc(section->rawsize);
++ bfd_get_section_contents(somebfd, section, inbuf, 0, section->rawsize);
+
+- send_data(inbuf, section->lma, section->_raw_size);
++ send_data(inbuf, section->lma, section->rawsize);
+
+ free(inbuf);
+ }
diff --git a/dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch b/dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch
new file mode 100644
index 000000000000..678278262900
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/files/dc-tool-ip-1.0.4-headers.patch
@@ -0,0 +1,22 @@
+--- a/host-src/tool/dc-tool.c
++++ b/host-src/tool/dc-tool.c
+@@ -24,6 +24,7 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #ifdef _WIN32
+ #include <string.h>
+ #include <windows.h>
+--- a/host-src/tool/syscalls.c
++++ b/host-src/tool/syscalls.c
+@@ -24,6 +24,9 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
++#include <arpa/inet.h>
++#include <time.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+ #include <utime.h>
diff --git a/dev-embedded/dc-tool-ip/metadata.xml b/dev-embedded/dc-tool-ip/metadata.xml
new file mode 100644
index 000000000000..9d638b815e71
--- /dev/null
+++ b/dev-embedded/dc-tool-ip/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>embedded</herd>
+ <maintainer>
+ <email>sh@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cadcdev</remote-id>
+ </upstream>
+</pkgmetadata>