summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild')
-rw-r--r--dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild b/dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild
new file mode 100644
index 000000000000..4f01cc7ef527
--- /dev/null
+++ b/dev-embedded/libftd2xx/libftd2xx-0.4.16-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Library that allows a direct access to a USB device"
+HOMEPAGE="http://www.ftdichip.com/Drivers/D2XX.htm"
+SRC_URI="amd64? ( http://www.ftdichip.com/Drivers/D2XX/Linux/${MY_P}_x86_64.tar.gz )
+ x86? ( http://www.ftdichip.com/Drivers/D2XX/Linux/${MY_P}.tar.gz )"
+
+LICENSE="FTDI LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+QA_PREBUILT="*"
+
+S=${WORKDIR}
+
+src_install() {
+ use x86 && cd ${MY_P}
+ use amd64 && cd ${MY_P}_x86_64
+
+ into /opt
+ dolib.so ${PN}.so.${PV}
+ dosym ${PN}.so.${PV} /opt/$(get_libdir)/${PN}.so.${PV:0:1}
+ dosym ${PN}.so.${PV:0:1} /opt/$(get_libdir)/${PN}.so
+ insinto /usr/include
+ doins ftd2xx.h WinTypes.h
+
+ dodir /etc/env.d
+ echo "LDPATH=\"/opt/$(get_libdir)\"" > ${D}/etc/env.d/50libftd2xx || die
+ if use examples ; then
+ find sample lib_table '(' -name '*.so' -o -name '*.[oa]' ')' -exec rm -f {} +
+ insinto /usr/share/doc/${PF}
+ doins -r sample
+ insinto /usr/share/doc/${PF}/sample
+ doins -r lib_table
+ fi
+
+ dodoc Config.txt
+ use x86 && dodoc faq.txt readme.dat
+ use amd64 && dodoc FAQ.txt README.dat
+}